about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>2021-01-03 00:40:43 +0000
committerThomas E. Dickey <dickey@invisible-island.net>2021-01-03 00:40:43 +0000
commitd27cb6a6d54843e3b3477d3474a9466b6f2fbf95 (patch)
tree253d47f21a37e379d8c9af1ded57e98e0d985d3b /configure.in
parentdba3a98fd307e9b0773e57206f0856a7f611a150 (diff)
downloadlynx-snapshots-d27cb6a6d54843e3b3477d3474a9466b6f2fbf95.tar.gz
snapshot of project "lynx", label v2-9-0dev_6b
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in162
1 files changed, 81 insertions, 81 deletions
diff --git a/configure.in b/configure.in
index 8e95e0bc..54c49bd6 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl $LynxId: configure.in,v 1.319 2020/11/26 19:25:38 tom Exp $
+dnl $LynxId: configure.in,v 1.323 2021/01/02 13:47:23 tom Exp $
 dnl
 dnl Process this file with autoconf to produce a configure script.
 dnl
@@ -7,7 +7,7 @@ dnl by T.E.Dickey <dickey@invisible-island.net>
 dnl and Jim Spath <jspath@mail.bcpl.lib.md.us>
 dnl
 dnl ---------------------------------------------------------------------------
-dnl Copyright 1997-2019,2020 by Thomas E. Dickey
+dnl Copyright 1997-2020,2021 by Thomas E. Dickey
 dnl
 dnl Permission to use, copy, modify, and distribute this software and its
 dnl documentation for any purpose and without fee is hereby granted,
@@ -85,7 +85,7 @@ dnl --------------------------------------------------------------------------
 
 dnl Only add to this case statement when a system has a compiler that is not
 dnl detected by AC_PROG_CC.
-case $host_os in
+case "$host_os" in
 (openedition)
 	: ${CFLAGS="-D_ALL_SOURCE -Wl,EDIT=NO"}
 	: ${CC=c89}
@@ -95,7 +95,7 @@ esac
 CF_PROG_CC
 CF_PROG_CPP_COMMENTS
 AC_PROG_LN_S
-case $host_os in
+case "$host_os" in
 (mingw*)
 LN_S="cp -p"
 AC_MSG_RESULT(Override: No symbolic links in mingw.)
@@ -154,7 +154,7 @@ CF_ARG_ENABLE(debug,
 	[with_debug=no])
 AC_MSG_RESULT($with_debug)
 if test "$with_debug" = "yes" ; then
-	case $host_os in
+	case "$host_os" in
 	(ultrix*|osf*)
 		test -z "$ORIGINAL_CFLAGS" && CF_STRIP_O_OPT(CFLAGS)
 		if test -z "$GCC" ; then
@@ -163,7 +163,7 @@ if test "$with_debug" = "yes" ; then
 		;;
 	esac
 else
-	case $host_os in
+	case "$host_os" in
 	(osf*)
 		test -z "$GCC" && CFLAGS="$CFLAGS -std1"
 		test -z "$ORIGINAL_CFLAGS" && CF_STRIP_G_OPT(CFLAGS)
@@ -180,7 +180,7 @@ CF_ARG_DISABLE(trace,
 	[with_trace=$enableval],
 	[with_trace=yes])
 AC_MSG_RESULT($with_trace)
-test $with_trace = no && AC_DEFINE(NO_LYNX_TRACE,1,[Define to 1 if you want to enable lynx trace code])
+test "$with_trace" = no && AC_DEFINE(NO_LYNX_TRACE,1,[Define to 1 if you want to enable lynx trace code])
 
 AC_MSG_CHECKING(if you want verbose trace code)
 CF_ARG_ENABLE(vertrace,
@@ -188,7 +188,7 @@ CF_ARG_ENABLE(vertrace,
 	[with_vertrace=yes],
 	[with_vertrace=no])
 AC_MSG_RESULT($with_vertrace)
-test $with_vertrace = yes && AC_DEFINE(LY_TRACELINE,__LINE__,[Define to __LINE__ if you want verbose trace code])
+test "$with_vertrace" = yes && AC_DEFINE(LY_TRACELINE,__LINE__,[Define to __LINE__ if you want verbose trace code])
 
 CF_WITH_SCREEN_PDCURSES
 CF_ENABLE_WARNINGS
@@ -204,7 +204,7 @@ AC_DEFINE(UNIX,1,[Define to 1 if we can run a configure script])
 
 dnl Only add to this case statement things that we cannot design tests for.
 TRY_CFLAGS=
-case $host_os in
+case "$host_os" in
 (aix4*)
 	TRY_CFLAGS="$TRY_CFLAGS -DAIX4 -D_BSD=44 -D_AIX"
 	LIBS="$LIBS -lbsd"
@@ -287,7 +287,7 @@ case $host_os in
 	TRY_CFLAGS="$TRY_CFLAGS -DDSYS5 -DSYS_TRU64"
 	;;
 (sco3.2v5*)
-	test $ac_cv_prog_gcc != yes && TRY_CFLAGS="$TRY_CFLAGS -belf"
+	test "$ac_cv_prog_gcc" != yes && TRY_CFLAGS="$TRY_CFLAGS -belf"
 	;;
 (sco*)
 	LIBS="$LIBS -lmalloc"
@@ -330,7 +330,7 @@ case $host_os in
 	;;
 esac
 
-case $host_os in
+case "$host_os" in
 (mingw*)
 	EXTRA_OBJS="$EXTRA_OBJS LYIcon\$o"
 	;;
@@ -352,7 +352,7 @@ dnl --------------------------------------------------------------------------
 
 dnl Set of available languages (based on source distribution)
 if test -z "$ALL_LINGUAS" ; then
-	ALL_LINGUAS=`test -d $srcdir/po && cd $srcdir/po && echo *.po|sed -e 's/\.po//g' -e 's/*//'`
+	ALL_LINGUAS=`test -d "$srcdir/po" && cd "$srcdir/po" && echo *.po|sed -e 's/\.po//g' -e 's/*//'`
 	AM_PATH_PROG_WITH_TEST(MSGINIT, msginit,
 		[$ac_dir/$ac_word --no-translator --version /dev/null >/dev/null 2>&1], :)
 	if test "$MSGINIT" != ":" ; then
@@ -383,7 +383,7 @@ CF_ARG_DISABLE(full-paths,
 	[with_full_paths=no],
 	[with_full_paths=yes])
 AC_MSG_RESULT($with_full_paths)
-test $with_full_paths = no && AC_DEFINE(USE_EXECVP,1,[Define to 1 if you want full utility pathnames])
+test "$with_full_paths" = no && AC_DEFINE(USE_EXECVP,1,[Define to 1 if you want full utility pathnames])
 
 CF_DEFINE_PROG(system mailer, SYSTEM_MAIL,
 	/usr/mmdf/bin/submit \
@@ -392,8 +392,8 @@ CF_DEFINE_PROG(system mailer, SYSTEM_MAIL,
 	)
 CF_SYSTEM_MAIL_FLAGS
 if test -n "$SYSTEM_MAIL" ; then
-if test $with_full_paths = no ; then
-	SYSTEM_MAIL=`basename $SYSTEM_MAIL`
+if test "$with_full_paths" = no ; then
+	SYSTEM_MAIL=`basename "$SYSTEM_MAIL"`
 fi
 fi
 
@@ -498,7 +498,7 @@ AC_ARG_WITH(screen,
 [  --with-screen=XXX       select screen type (XXX is curses (default),
                           ncurses, ncursesw, pdcurses or slang)],
 	[
-case $withval in
+case "$withval" in
 (curses|ncurses*|pdcurses|slang)
 	cf_cv_screen=$withval
 	;;
@@ -507,7 +507,7 @@ case $withval in
 esac],
 	[cf_cv_screen=curses])])
 
-case $cf_cv_screen in
+case "$cf_cv_screen" in
 (curses|ncurses*)
 	CF_WITH_CURSES_DIR
 	;;
@@ -515,7 +515,7 @@ esac
 
 cf_wide_curses=no
 dft_color_style=yes
-case $cf_cv_screen in
+case "$cf_cv_screen" in
 (curses)
 	CF_CURSES_CONFIG
 	CF_CURS_PERFORMANCE
@@ -530,7 +530,7 @@ case $cf_cv_screen in
 	CF_NCURSES_CONFIG($cf_cv_screen)
 	;;
 (pdcurses)
-	case $host_os in
+	case "$host_os" in
 	(mingw*)
 		cf_cv_ncurses_header=curses.h
 		;;
@@ -563,7 +563,7 @@ CF_ARG_DISABLE(color-style,
 	[use_color_style=$enableval],
 	[use_color_style=$dft_color_style])
 
-case $use_color_style in
+case "$use_color_style" in
 (no)
 	AC_MSG_RESULT(no)
 	INSTALL_LSS=
@@ -620,7 +620,7 @@ $sysconfdir)
 
 AC_MSG_RESULT($LYNX_CFG_PATH)
 
-test -z "$LYNX_CFG_PATH" && `echo "$LYNX_CFG_FILE" | sed -e 's%/[[^/]]*$%%'`
+test -z "$LYNX_CFG_PATH" && LYNX_CFG_PATH="`echo "$LYNX_CFG_FILE" | sed -e 's%/[[^/]]*$%%'`"
 test "x$LYNX_CFG_PATH" = xno && LYNX_CFG_PATH=
 AC_DEFINE_UNQUOTED(LYNX_CFG_PATH,"$LYNX_CFG_PATH",[Define to default path for Lynx config-files])
 
@@ -633,7 +633,7 @@ CF_ARG_ENABLE(htmlized-cfg,
 AC_MSG_RESULT($use_htmlized_cfg)
 
 LYNXCFG_MAKE=''
-if test $use_htmlized_cfg = no ; then
+if test "$use_htmlized_cfg" = no ; then
 	LYNXCFG_MAKE='#'
 fi
 AC_SUBST(LYNXCFG_MAKE)
@@ -647,7 +647,7 @@ CF_ARG_ENABLE(local-docs,
 AC_MSG_RESULT($use_local_docs)
 
 LYNXDOC_MAKE=''
-if test $use_local_docs = no ; then
+if test "$use_local_docs" = no ; then
 	LYNXDOC_MAKE='#'
 fi
 AC_SUBST(LYNXDOC_MAKE)
@@ -670,7 +670,7 @@ CF_ARG_DISABLE(locale-charset,
 	[use_locale_charset=$enableval],
 	[use_locale_charset=yes])
 AC_MSG_RESULT($use_locale_charset)
-test $use_locale_charset != no && AC_DEFINE(USE_LOCALE_CHARSET,1,[Define to 1 if locale-charset selection logic should be used])
+test "$use_locale_charset" != no && AC_DEFINE(USE_LOCALE_CHARSET,1,[Define to 1 if locale-charset selection logic should be used])
 
 dnl --------------------------------------------------------------------------
 dnl Check for subsets of compiled-in tables.
@@ -694,13 +694,13 @@ if test -n "$cf_charsets" ; then
 	if test "$cf_charsets" = "minimal" ; then
 		CF_VERBOSE(using minimal list of charsets: $cf_min_charsets)
 	fi
-	cf_charsets=`echo $cf_charsets | sed -e "s/minimal/$cf_min_charsets/g" -e 's/,/ /g'`
+	cf_charsets=`echo "$cf_charsets" | sed -e "s/minimal/$cf_min_charsets/g" -e 's/,/ /g'`
 	for cf_charset in $cf_charsets
 	do
-		cf_def_charset=`echo $cf_charset | sed -e 's/+/_/g' -e 's/-/_/g'`
+		cf_def_charset=`echo "$cf_charset" | sed -e 's/+/_/g' -e 's/-/_/g'`
 		cf_use_charset=no
 		# check charsets that are defined via .tbl files
-		if ( egrep '^M'$cf_charset'$' $srcdir/src/chrtrans/*.tbl 2>/dev/null >/dev/null )
+		if ( egrep '^M'$cf_charset'$' "$srcdir"/src/chrtrans/*.tbl 2>/dev/null >/dev/null )
 		then
 			cf_use_charset=yes
 		# check charsets that are "built-in"
@@ -714,7 +714,7 @@ if test -n "$cf_charsets" ; then
 				fi
 			done
 		fi
-		if test $cf_use_charset=yes
+		if test "$cf_use_charset" = yes
 		then
 			CF_VERBOSE(found $cf_charset)
 			CHARSET_DEFS="-DNO_CHARSET_${cf_def_charset}=0 $CHARSET_DEFS"
@@ -857,7 +857,7 @@ CF_ARG_DISABLE(bibp-urls,
 	[use_bibp_urls=$enableval],
 	[use_bibp_urls=yes])
 AC_MSG_RESULT($use_bibp_urls)
-test $use_bibp_urls = no && AC_DEFINE(DISABLE_BIBP,1,[Define to 1 if bibp: URLs should be supported])
+test "$use_bibp_urls" = no && AC_DEFINE(DISABLE_BIBP,1,[Define to 1 if bibp: URLs should be supported])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if configuration info should be browsable)
@@ -866,7 +866,7 @@ CF_ARG_DISABLE(config-info,
 	[use_config_info=$enableval],
 	[use_config_info=yes])
 AC_MSG_RESULT($use_config_info)
-test $use_config_info = no && AC_DEFINE(NO_CONFIG_INFO,1,[Define to 1 if configuration info should be browsable])
+test "$use_config_info" = no && AC_DEFINE(NO_CONFIG_INFO,1,[Define to 1 if configuration info should be browsable])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if new-style forms-based options screen should be used)
@@ -875,7 +875,7 @@ CF_ARG_DISABLE(forms-options,
 	[use_forms_options=$enableval],
 	[use_forms_options=yes])
 AC_MSG_RESULT($use_forms_options)
-test $use_forms_options = no && AC_DEFINE(NO_OPTION_FORMS,1,[Define to 1 if new-style forms-based options screen should be used])
+test "$use_forms_options" = no && AC_DEFINE(NO_OPTION_FORMS,1,[Define to 1 if new-style forms-based options screen should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if old-style options menu should be used)
@@ -884,7 +884,7 @@ CF_ARG_DISABLE(menu-options,
 	[use_menu_options=$enableval],
 	[use_menu_options=yes])
 AC_MSG_RESULT($use_menu_options)
-test $use_menu_options = no && AC_DEFINE(NO_OPTION_MENU,1,[Define to 1 if old-style options menu should be used])
+test "$use_menu_options" = no && AC_DEFINE(NO_OPTION_MENU,1,[Define to 1 if old-style options menu should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if sessions code should be used)
@@ -893,7 +893,7 @@ CF_ARG_DISABLE(sessions,
 	[use_sessions=$enableval],
 	[use_sessions=yes])
 AC_MSG_RESULT($use_sessions)
-if test $use_sessions != no ; then
+if test "$use_sessions" != no ; then
 	AC_DEFINE(USE_SESSIONS,1,[Define to 1 if sessions code should be used])
 	EXTRA_OBJS="$EXTRA_OBJS LYSession\$o"
 fi
@@ -905,7 +905,7 @@ CF_ARG_DISABLE(session-cache,
 	[use_session_cache=$enableval],
 	[use_session_cache=yes])
 AC_MSG_RESULT($use_session_cache)
-if test $use_session_cache != no ; then
+if test "$use_session_cache" != no ; then
     AC_DEFINE(USE_CACHEJAR,1,[Define to 1 if session-caching code should be used])
 fi
 
@@ -916,7 +916,7 @@ CF_ARG_DISABLE(addrlist-page,
 	[use_addrlist_page=$enableval],
 	[use_addrlist_page=yes])
 AC_MSG_RESULT($use_addrlist_page)
-test $use_addrlist_page != no && AC_DEFINE(USE_ADDRLIST_PAGE,1,[Define to 1 if address-list page should be used])
+test "$use_addrlist_page" != no && AC_DEFINE(USE_ADDRLIST_PAGE,1,[Define to 1 if address-list page should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if experimental CJK logic should be used)
@@ -925,7 +925,7 @@ CF_ARG_ENABLE(cjk,
 	[use_cjk=$enableval],
 	[use_cjk=no])
 AC_MSG_RESULT($use_cjk)
-test $use_cjk != no && AC_DEFINE(CJK_EX,1,[Define to 1 if experimental CJK logic should be used])
+test "$use_cjk" != no && AC_DEFINE(CJK_EX,1,[Define to 1 if experimental CJK logic should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if experimental Japanese UTF-8 logic should be used)
@@ -934,7 +934,7 @@ CF_ARG_ENABLE(japanese-utf8,
 	[use_ja_utf8=$enableval],
 	[use_ja_utf8=no])
 AC_MSG_RESULT($use_ja_utf8)
-if test $use_ja_utf8 != no ; then
+if test "$use_ja_utf8" != no ; then
 	AC_DEFINE(EXP_JAPANESEUTF8_SUPPORT,1,[Define to 1 if experimental Japanese UTF-8 logic should be used])
 	AM_ICONV
 	if test "$USE_NLS" != yes ; then
@@ -949,11 +949,11 @@ CF_ARG_ENABLE(wcwidth-support,
 	[use_wcwidth=$enableval],
 	[use_wcwidth=no])
 AC_MSG_RESULT($use_wcwidth)
-test $use_wcwidth != no && AC_DEFINE(EXP_WCWIDTH_SUPPORT,1,[Define to 1 if experimental wcwidth/UTF-8 logic should be used])
+test "$use_wcwidth" != no && AC_DEFINE(EXP_WCWIDTH_SUPPORT,1,[Define to 1 if experimental wcwidth/UTF-8 logic should be used])
 
 dnl --------------------------------------------------------------------------
 use_dft_colors=no
-case $cf_cv_screen in
+case "$cf_cv_screen" in
 (curses|slang|ncurses*)
 	use_dft_colors=maybe
 	;;
@@ -966,7 +966,7 @@ CF_ARG_ENABLE(default-colors,
 	[use_dft_colors=yes],
 	[use_dft_colors=no])
 AC_MSG_RESULT($use_dft_colors)
-test $use_dft_colors = "yes" && AC_DEFINE(USE_DEFAULT_COLORS,1,[Define to 1 if you want to use default-colors])
+test "$use_dft_colors" = "yes" && AC_DEFINE(USE_DEFAULT_COLORS,1,[Define to 1 if you want to use default-colors])
 fi
 
 dnl --------------------------------------------------------------------------
@@ -976,7 +976,7 @@ CF_ARG_ENABLE(kbd-layout,
 	[use_kbd_layout=$enableval],
 	[use_kbd_layout=no])
 AC_MSG_RESULT($use_kbd_layout)
-test $use_kbd_layout != no && AC_DEFINE(EXP_KEYBOARD_LAYOUT,1,[Define to 1 if experimental keyboard-layout logic should be used])
+test "$use_kbd_layout" != no && AC_DEFINE(EXP_KEYBOARD_LAYOUT,1,[Define to 1 if experimental keyboard-layout logic should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if experimental nested-table logic should be used)
@@ -985,7 +985,7 @@ CF_ARG_ENABLE(nested-tables,
 	[use_nested_tables=$enableval],
 	[use_nested_tables=no])
 AC_MSG_RESULT($use_nested_tables)
-test $use_nested_tables != no && AC_DEFINE(EXP_NESTED_TABLES,1,[Define to 1 if experimental nested-table logic should be used])
+test "$use_nested_tables" != no && AC_DEFINE(EXP_NESTED_TABLES,1,[Define to 1 if experimental nested-table logic should be used])
 
 dnl --------------------------------------------------------------------------
 dnl Miscellaneous options that don't need to test system features
@@ -1001,7 +1001,7 @@ CF_ARG_DISABLE(alt-bindings,
 	[use_alt_bindings=$enableval],
 	[use_alt_bindings=yes])
 AC_MSG_RESULT($use_alt_bindings)
-test $use_alt_bindings != no && AC_DEFINE(USE_ALT_BINDINGS,1,[Define to 1 if alternative line-edit bindings should be used])
+test "$use_alt_bindings" != no && AC_DEFINE(USE_ALT_BINDINGS,1,[Define to 1 if alternative line-edit bindings should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if ascii case-conversion should be used)
@@ -1010,7 +1010,7 @@ CF_ARG_DISABLE(ascii-ctypes,
 	[use_ascii_ctypes=$enableval],
 	[use_ascii_ctypes=yes])
 AC_MSG_RESULT($use_ascii_ctypes)
-test $use_ascii_ctypes != no && AC_DEFINE(USE_ASCII_CTYPES,1,[Define to 1 if ascii case-conversion should be used])
+test "$use_ascii_ctypes" != no && AC_DEFINE(USE_ASCII_CTYPES,1,[Define to 1 if ascii case-conversion should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to use extended HTML DTD logic)
@@ -1019,7 +1019,7 @@ CF_ARG_DISABLE(extended-dtd,
 	[use_ext_htmldtd=no],
 	[use_ext_htmldtd=yes])
 AC_MSG_RESULT($use_ext_htmldtd)
-test $use_ext_htmldtd = "no" && AC_DEFINE(NO_EXTENDED_HTMLDTD,1,[Define to 1 if you want to use extended HTML DTD logic])
+test "$use_ext_htmldtd" = "no" && AC_DEFINE(NO_EXTENDED_HTMLDTD,1,[Define to 1 if you want to use extended HTML DTD logic])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if file-upload logic should be used)
@@ -1028,7 +1028,7 @@ CF_ARG_DISABLE(file-upload,
 	[use_file_upload=$enableval],
 	[use_file_upload=yes])
 AC_MSG_RESULT($use_file_upload)
-test $use_file_upload != no && AC_DEFINE(USE_FILE_UPLOAD,1,[Define to 1 if file-upload logic should be used])
+test "$use_file_upload" != no && AC_DEFINE(USE_FILE_UPLOAD,1,[Define to 1 if file-upload logic should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if IDNA support should be used)
@@ -1049,7 +1049,7 @@ CF_ARG_DISABLE(justify-elts,
 	[use_justify_elts=$enableval],
 	[use_justify_elts=yes])
 AC_MSG_RESULT($use_justify_elts)
-test $use_justify_elts != no && AC_DEFINE(USE_JUSTIFY_ELTS,1,[Define to 1 if element-justification logic should be used])
+test "$use_justify_elts" != no && AC_DEFINE(USE_JUSTIFY_ELTS,1,[Define to 1 if element-justification logic should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if partial-display should be used)
@@ -1058,7 +1058,7 @@ CF_ARG_DISABLE(partial,
 	[use_partial_display=$enableval],
 	[use_partial_display=yes])
 AC_MSG_RESULT($use_partial_display)
-test $use_partial_display != no && AC_DEFINE(DISP_PARTIAL,1,[Define to 1 if partial-display should be used])
+test "$use_partial_display" != no && AC_DEFINE(DISP_PARTIAL,1,[Define to 1 if partial-display should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if persistent-cookie logic should be used)
@@ -1067,7 +1067,7 @@ CF_ARG_DISABLE(persistent-cookies,
 	[use_filed_cookies=$enableval],
 	[use_filed_cookies=yes])
 AC_MSG_RESULT($use_filed_cookies)
-test $use_filed_cookies != no && AC_DEFINE(USE_PERSISTENT_COOKIES,1,[Define to 1 if persistent-cookie logic should be used])
+test "$use_filed_cookies" != no && AC_DEFINE(USE_PERSISTENT_COOKIES,1,[Define to 1 if persistent-cookie logic should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if html source should be colorized)
@@ -1076,7 +1076,7 @@ CF_ARG_DISABLE(prettysrc,
 	[use_prettysrc=$enableval],
 	[use_prettysrc=yes])
 AC_MSG_RESULT($use_prettysrc)
-test $use_prettysrc != no && AC_DEFINE(USE_PRETTYSRC,1,[Define to 1 if html source should be colorized])
+test "$use_prettysrc" != no && AC_DEFINE(USE_PRETTYSRC,1,[Define to 1 if html source should be colorized])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if progress-bar code should be used)
@@ -1085,7 +1085,7 @@ CF_ARG_DISABLE(progressbar,
 	[use_progressbar=$enableval],
 	[use_progressbar=yes])
 AC_MSG_RESULT($use_progressbar)
-test $use_progressbar != no && AC_DEFINE(USE_PROGRESSBAR,1,[Define to 1 if progress-bar code should be used])
+test "$use_progressbar" != no && AC_DEFINE(USE_PROGRESSBAR,1,[Define to 1 if progress-bar code should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if read-progress message should show ETA)
@@ -1094,7 +1094,7 @@ CF_ARG_DISABLE(read-eta,
 	[use_read_eta=$enableval],
 	[use_read_eta=yes])
 AC_MSG_RESULT($use_read_eta)
-test $use_read_eta != no && AC_DEFINE(USE_READPROGRESS,1,[Define to 1 if read-progress message should show ETA])
+test "$use_read_eta" != no && AC_DEFINE(USE_READPROGRESS,1,[Define to 1 if read-progress message should show ETA])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if source caching should be used)
@@ -1103,7 +1103,7 @@ CF_ARG_DISABLE(source-cache,
 	[use_source_cache=$enableval],
 	[use_source_cache=yes])
 AC_MSG_RESULT($use_source_cache)
-test $use_source_cache != no && AC_DEFINE(USE_SOURCE_CACHE,1,[Define to 1 if source caching should be used])
+test "$use_source_cache" != no && AC_DEFINE(USE_SOURCE_CACHE,1,[Define to 1 if source caching should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if scrollbar code should be used)
@@ -1120,7 +1120,7 @@ CF_ARG_ENABLE(charset-choice,
 	[use_charset_choice=$enableval],
 	[use_charset_choice=no])
 AC_MSG_RESULT($use_charset_choice)
-test $use_charset_choice != no && AC_DEFINE(USE_CHARSET_CHOICE,1,[Define to 1 if charset-selection logic should be used])
+test "$use_charset_choice" != no && AC_DEFINE(USE_CHARSET_CHOICE,1,[Define to 1 if charset-selection logic should be used])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to use external commands)
@@ -1129,7 +1129,7 @@ CF_ARG_ENABLE(externs,
 	[use_externs=yes],
 	[use_externs=no])
 AC_MSG_RESULT($use_externs)
-if test $use_externs != "no" ; then
+if test "$use_externs" != "no" ; then
 	AC_DEFINE(USE_EXTERNALS,1,[Define to 1 if you want to use external commands])
 	EXTRA_OBJS="$EXTRA_OBJS LYExtern\$o"
 fi
@@ -1141,8 +1141,8 @@ CF_ARG_ENABLE(font-switch,
 	[use_setfont=yes],
 	[use_setfont=no])
 AC_MSG_RESULT($use_setfont)
-if test $use_setfont = yes ; then
-	case $host_os in
+if test "$use_setfont" = yes ; then
+	case "$host_os" in
 	(linux*)
 		CF_PATH_PROG(SETFONT, consolechars, setfont)
 		;;
@@ -1176,7 +1176,7 @@ CF_ARG_ENABLE(change-exec,
 	[use_change_exec=yes],
 	[use_change_exec=no])
 AC_MSG_RESULT($use_change_exec)
-test $use_change_exec = yes && AC_DEFINE(ENABLE_OPTS_CHANGE_EXEC,1,[Define to 1 if you want change-exec support])
+test "$use_change_exec" = yes && AC_DEFINE(ENABLE_OPTS_CHANGE_EXEC,1,[Define to 1 if you want change-exec support])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want exec-links support)
@@ -1186,7 +1186,7 @@ CF_ARG_OPTION(exec-links,
 	[use_exec_links=$enableval],
 	[$use_change_exec])
 AC_MSG_RESULT($use_exec_links)
-test $use_exec_links = yes && AC_DEFINE(EXEC_LINKS,1,[Define to 1 if you want exec-links support])
+test "$use_exec_links" = yes && AC_DEFINE(EXEC_LINKS,1,[Define to 1 if you want exec-links support])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want exec-scripts support)
@@ -1196,7 +1196,7 @@ CF_ARG_OPTION(exec-scripts,
 	[use_exec_scripts=$enableval],
 	[$use_change_exec])
 AC_MSG_RESULT($use_exec_scripts)
-test $use_exec_scripts = yes && AC_DEFINE(EXEC_SCRIPTS,1,[Define to 1 if you want exec-scripts support])
+test "$use_exec_scripts" = yes && AC_DEFINE(EXEC_SCRIPTS,1,[Define to 1 if you want exec-scripts support])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want internal-links feature)
@@ -1205,7 +1205,7 @@ CF_ARG_ENABLE(internal-links,
 	[use_internal_links=yes],
 	[use_internal_links=no])
 AC_MSG_RESULT($use_internal_links)
-test $use_internal_links = yes && AC_DEFINE(TRACK_INTERNAL_LINKS,1,[Define to 1 if you want internal-links feature])
+test "$use_internal_links" = yes && AC_DEFINE(TRACK_INTERNAL_LINKS,1,[Define to 1 if you want internal-links feature])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to fork NSL requests)
@@ -1214,8 +1214,8 @@ CF_ARG_ENABLE(nsl-fork,
 	[use_nsl_fork=yes],
 	[use_nsl_fork=no])
 AC_MSG_RESULT($use_nsl_fork)
-if test $use_nsl_fork = yes ; then
-	case $host_os in
+if test "$use_nsl_fork" = yes ; then
+	case "$host_os" in
 	(mingw*)
 		AC_DEFINE(_WINDOWS_NSL,1,[Define to 1 if we want NSL-fork with Windows])
 		;;
@@ -1232,7 +1232,7 @@ CF_ARG_ENABLE(syslog,
 	[use_syslog=yes],
 	[use_syslog=no])
 AC_MSG_RESULT($use_syslog)
-test $use_syslog = yes && AC_DEFINE(SYSLOG_REQUESTED_URLS,1,[Define to 1 if you want to log URL requests via syslog])
+test "$use_syslog" = yes && AC_DEFINE(SYSLOG_REQUESTED_URLS,1,[Define to 1 if you want to log URL requests via syslog])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to underline links)
@@ -1241,8 +1241,8 @@ CF_ARG_ENABLE(underlines,
 	[use_underline=yes],
 	[use_underline=no])
 AC_MSG_RESULT($use_underline)
-test $use_underline = yes && AC_DEFINE(UNDERLINE_LINKS,1,[Define to 1 if xxx])
-test $use_underline = no  && AC_DEFINE(UNDERLINE_LINKS,0,[Define to 0 if xxx])
+test "$use_underline" = yes && AC_DEFINE(UNDERLINE_LINKS,1,[Define to 1 if xxx])
+test "$use_underline" = no  && AC_DEFINE(UNDERLINE_LINKS,0,[Define to 0 if xxx])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if help files should be gzip'ed)
@@ -1289,7 +1289,7 @@ CF_ARG_DISABLE(finger,
 	[use_finger=yes],
 	[use_finger=no])
 AC_MSG_RESULT($use_finger)
-test $use_finger != "no" && AC_DEFINE(DISABLE_FINGER,1,[Define to 1 if you want to exclude FINGER code])
+test "$use_finger" != "no" && AC_DEFINE(DISABLE_FINGER,1,[Define to 1 if you want to exclude FINGER code])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to exclude GOPHER code)
@@ -1298,7 +1298,7 @@ CF_ARG_DISABLE(gopher,
 	[use_gopher=yes],
 	[use_gopher=no])
 AC_MSG_RESULT($use_gopher)
-test $use_gopher != "no" && AC_DEFINE(DISABLE_GOPHER,1,[Define to 1 if you want to exclude GOPHER code])
+test "$use_gopher" != "no" && AC_DEFINE(DISABLE_GOPHER,1,[Define to 1 if you want to exclude GOPHER code])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to exclude NEWS code)
@@ -1307,7 +1307,7 @@ CF_ARG_DISABLE(news,
       [use_news=yes],
       [use_news=no])
 AC_MSG_RESULT($use_news)
-test $use_news != "no" && AC_DEFINE(DISABLE_NEWS,1,[Define to 1 if you want to exclude NEWS code])
+test "$use_news" != "no" && AC_DEFINE(DISABLE_NEWS,1,[Define to 1 if you want to exclude NEWS code])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to exclude FTP code)
@@ -1316,7 +1316,7 @@ CF_ARG_DISABLE(ftp,
       [use_ftp=yes],
       [use_ftp=no])
 AC_MSG_RESULT($use_ftp)
-test $use_ftp != "no" && AC_DEFINE(DISABLE_FTP,1,[Define to 1 if you want to exclude FTP code])
+test "$use_ftp" != "no" && AC_DEFINE(DISABLE_FTP,1,[Define to 1 if you want to exclude FTP code])
 
 dnl --------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to include WAIS code)
@@ -1327,7 +1327,7 @@ CF_ARG_ENABLE(wais,
 AC_MSG_RESULT($use_wais)
 
 MAKE_WAIS="#"
-if test $use_wais != "no"
+if test "$use_wais" != "no"
 then
 	AC_CHECK_LIB(wais,fs_free,[
 		CF_MATH_LIB
@@ -1460,16 +1460,16 @@ fi
 
 COMPRESS_PROG=
 COMPRESS_EXT=
-if test $use_gzip_help = yes ; then
+if test "$use_gzip_help" = yes ; then
 	COMPRESS_PROG="$ac_cv_path_GZIP -9 -n"
 	COMPRESS_EXT=.gz
 fi
 AC_SUBST(COMPRESS_PROG)
 AC_SUBST(COMPRESS_EXT)
 
-if test $cf_cv_screen = pdcurses ; then
+if test "$cf_cv_screen" = pdcurses ; then
 	CF_HELP_MESSAGE(Special Libraries for PDCurses X11:)
-	case $host_os in
+	case "$host_os" in
 	(mingw*)
 		CF_PDCURSES_W32
 		;;
@@ -1482,8 +1482,8 @@ else
 fi
 
 ### These tests must be run after establishing the curses library.
-if test $cf_cv_screen != slang ; then
-	if test $cf_cv_screen != pdcurses ; then
+if test "$cf_cv_screen" != slang ; then
+	if test "$cf_cv_screen" != pdcurses ; then
 		AC_CHECK_HEADERS($cf_cv_screen/term.h term.h)
 	fi
 	CF_ALT_CHAR_SET
@@ -1526,16 +1526,16 @@ if test $cf_cv_screen != slang ; then
 		)
 fi
 
-if test $use_color_style != no ; then
+if test "$use_color_style" != no ; then
 	if test .$cf_cv_color_curses != .yes ; then
 		AC_ERROR(Configuration does not support color-styles)
 	fi
-	if test $cf_cv_screen = slang ; then
+	if test "$cf_cv_screen" = slang ; then
 		AC_ERROR(Configuration does not support color-styles)
 	fi
 fi
 
-if test $use_scrollbar != no ; then
+if test "$use_scrollbar" != no ; then
 	if test .$cf_cv_fancy_curses != .yes ; then
 		AC_MSG_WARN(Configuration does not support ACS_xxx definitions)
 	else
@@ -1555,7 +1555,7 @@ AC_SUBST(CONFIG_SHELL)
 srcdir="$srcdir"
 SRCDIR_CLEAN="#"
 if test -n "$srcdir" ; then
-	echo srcdir is $srcdir
+	echo "srcdir is $srcdir"
 	mkdir -p WWW/Library/Implementation
 	mkdir -p src/chrtrans
 	test "$USE_INCLUDED_LIBINTL" = yes && mkdir -p intl
@@ -1576,7 +1576,7 @@ AC_OUTPUT(
 	],[
 	if test "$USE_NLS" = yes ; then
 	if test "$use_our_messages" = yes ; then
-		echo creating po/makefile
+		echo "creating po/makefile"
 		rm -f	po/temp$$
 		sed	-e 's%^.*LYMessages.c%	../LYMessages.c%' \
 			-e '$s/\\//' po/POTFILES >po/temp$$