about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1999-03-04 10:56:18 -0500
committerThomas E. Dickey <dickey@invisible-island.net>1999-03-04 10:56:18 -0500
commitf7c3c4ca429260c4d056b1e032e05162e25554ca (patch)
tree8317fd8852ed2996cf2edf2838c7f43f4023bcd5 /configure.in
parentc5fef0d4ab035d8fd988270a39ed6f9d0e9b214c (diff)
downloadlynx-snapshots-f7c3c4ca429260c4d056b1e032e05162e25554ca.tar.gz
snapshot of project "lynx", label v2-8-2dev_18
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in127
1 files changed, 92 insertions, 35 deletions
diff --git a/configure.in b/configure.in
index 4fb9a432..a327e921 100644
--- a/configure.in
+++ b/configure.in
@@ -57,7 +57,7 @@ test "$with_leak_checks" = "yes" && AC_DEFINE(LY_FIND_LEAKS)
 
 AC_MSG_CHECKING(if you want to enable debug-code)
 CF_ARG_ENABLE(debug,
-	[  --enable-debug          logic for traces/debugging],
+	[  --enable-debug          logic for object code debugging],
 	[with_debug=yes],
 	[with_debug=no])
 AC_MSG_RESULT($with_debug)
@@ -82,6 +82,13 @@ else
 	esac
 fi
 
+AC_MSG_CHECKING(if you want to enable lynx trace code *recommended* )
+CF_ARG_DISABLE(trace,
+	[  --disable-trace         disable logic for trace code],
+	[with_trace=$enableval],
+	[with_trace=yes])
+AC_MSG_RESULT($with_trace)
+test $with_trace = no && AC_DEFINE(NO_LYNX_TRACE)
 
 if test -n "$GCC"
 then
@@ -117,7 +124,22 @@ INTLDIR_MAKE=
 MSG_DIR_MAKE=
 SUB_MAKEFILE=
 if test "$USE_INCLUDED_LIBINTL" = yes ; then
-	SUB_MAKEFILE="intl/makefile po/makefile.in:po/makefile.inn"
+        if test "$nls_cv_force_use_gnu_gettext" = yes ; then
+		AC_MSG_WARN(Using included gettext anyway, since none was found)
+		SUB_MAKEFILE="intl/makefile"
+	else
+		INTLDIR_MAKE="#"
+	fi
+	CF_OUR_MESSAGES
+	if test $use_our_messages = no ; then
+		MSG_DIR_MAKE="#"
+		SUB_MAKEFILE=
+	fi
+	if test "$use_our_messages" = yes ; then
+		SUB_MAKEFILE="$SUB_MAKEFILE po/makefile.in:po/makefile.inn"
+	else
+		MSG_DIR_MAKE="#"
+	fi
 elif test "$USE_NLS" = yes ; then
 	AC_CHECK_HEADERS(libintl.h)
 	INTLDIR_MAKE="#"
@@ -499,11 +521,19 @@ if test $cf_cv_screen != slang ; then
 fi
 
 dnl --------------------------------------------------------------------------
-dnl Miscellaneous options that don't need to test system features
+dnl Experimental options that don't need to test system features
 dnl --------------------------------------------------------------------------
 
 CF_HELP_MESSAGE(
-Miscellaneous Options:)
+Experimental Options:)
+
+AC_MSG_CHECKING(if configuration info should be browsable)
+CF_ARG_DISABLE(config-info,
+[  --disable-config-info   disable browsable configuration-info],
+	[use_config_info=$enableval],
+	[use_config_info=yes])
+AC_MSG_RESULT($use_config_info)
+test $use_config_info = no && AC_DEFINE(NO_CONFIG_INFO)
 
 AC_MSG_CHECKING(if new-style forms-based options screen should be used)
 CF_ARG_DISABLE(forms-options,
@@ -521,13 +551,13 @@ CF_ARG_DISABLE(menu-options,
 AC_MSG_RESULT($use_menu_options)
 test $use_menu_options = no && AC_DEFINE(NO_OPTION_MENU)
 
-AC_MSG_CHECKING(if configuration info should be browsable)
-CF_ARG_DISABLE(config-info,
-[  --disable-config-info   disable browsable configuration-info],
-	[use_config_info=$enableval],
-	[use_config_info=yes])
-AC_MSG_RESULT($use_config_info)
-test $use_config_info = no && AC_DEFINE(NO_CONFIG_INFO)
+AC_MSG_CHECKING(if experimental address-list page should be used)
+CF_ARG_ENABLE(addrlist-page,
+[  --enable-addrlist-page  use experimental address-list page],
+	[use_addrlist_page=$enableval],
+	[use_addrlist_page=no])
+AC_MSG_RESULT($use_addrlist_page)
+test $use_addrlist_page != no && AC_DEFINE(EXP_ADDRLIST_PAGE)
 
 AC_MSG_CHECKING(if experimental alternative line-edit bindings should be used)
 CF_ARG_ENABLE(alt-bindings,
@@ -537,22 +567,6 @@ CF_ARG_ENABLE(alt-bindings,
 AC_MSG_RESULT($use_alt_bindings)
 test $use_alt_bindings != no && AC_DEFINE(EXP_ALT_BINDINGS)
 
-AC_MSG_CHECKING(if experimental keyboard-layout logic should be used)
-CF_ARG_ENABLE(kbd-layout,
-[  --enable-kbd-layout     use experimental keyboard-layout support],
-	[use_kbd_layout=$enableval],
-	[use_kbd_layout=no])
-AC_MSG_RESULT($use_kbd_layout)
-test $use_kbd_layout != no && AC_DEFINE(EXP_KEYBOARD_LAYOUT)
-
-AC_MSG_CHECKING(if experimental persistent-cookie logic should be used)
-CF_ARG_ENABLE(persistent-cookies,
-[  --enable-persistent-cookies   use experimental persistent-cookie support],
-	[use_filed_cookies=$enableval],
-	[use_filed_cookies=no])
-AC_MSG_RESULT($use_filed_cookies)
-test $use_filed_cookies != no && AC_DEFINE(EXP_PERSISTENT_COOKIES)
-
 AC_MSG_CHECKING(if color-style code should be used)
 CF_ARG_ENABLE(color-style,
 [  --enable-color-style    use optional/experimental color style],
@@ -588,14 +602,6 @@ no)
 esac
 AC_SUBST(INSTALL_LSS)
 
-AC_MSG_CHECKING(if partial-display should be used)
-CF_ARG_DISABLE(partial,
-[  --disable-partial       use partial-display logic],
-	[use_partial_display=$enableval],
-	[use_partial_display=yes])
-AC_MSG_RESULT($use_partial_display)
-test $use_partial_display != no && AC_DEFINE(DISP_PARTIAL)
-
 use_dft_colors=no
 test ".$cf_cv_screen" = ".slang"                && use_dft_colors=maybe
 test ".$ac_cv_func_use_default_colors" = ".yes" && use_dft_colors=maybe
@@ -610,6 +616,37 @@ AC_MSG_RESULT($use_dft_colors)
 test $use_dft_colors = "yes" && AC_DEFINE(USE_DEFAULT_COLORS)
 fi
 
+AC_MSG_CHECKING(if experimental keyboard-layout logic should be used)
+CF_ARG_ENABLE(kbd-layout,
+[  --enable-kbd-layout     use experimental keyboard-layout support],
+	[use_kbd_layout=$enableval],
+	[use_kbd_layout=no])
+AC_MSG_RESULT($use_kbd_layout)
+test $use_kbd_layout != no && AC_DEFINE(EXP_KEYBOARD_LAYOUT)
+
+AC_MSG_CHECKING(if experimental JavaScript support should be used)
+CF_ARG_ENABLE(libjs,
+[  --enable-libjs          use experimental JavaScript support (Mozilla libjs)],
+	[use_libjs=$enableval],
+	[use_libjs=no])
+AC_MSG_RESULT($use_libjs)
+test $use_libjs != no && AC_DEFINE(EXP_LIBJS)
+
+AC_MSG_CHECKING(if experimental persistent-cookie logic should be used)
+CF_ARG_ENABLE(persistent-cookies,
+[  --enable-persistent-cookies  use experimental persistent-cookie support],
+	[use_filed_cookies=$enableval],
+	[use_filed_cookies=no])
+AC_MSG_RESULT($use_filed_cookies)
+test $use_filed_cookies != no && AC_DEFINE(EXP_PERSISTENT_COOKIES)
+
+dnl --------------------------------------------------------------------------
+dnl Miscellaneous options that don't need to test system features
+dnl --------------------------------------------------------------------------
+
+CF_HELP_MESSAGE(
+Miscellaneous Options:)
+
 AC_MSG_CHECKING(if you want to use extended HTML DTD logic)
 CF_ARG_DISABLE(extended-dtd,
 [  --disable-extended-dtd  disable extended HTML DTD logic],
@@ -618,6 +655,14 @@ CF_ARG_DISABLE(extended-dtd,
 AC_MSG_RESULT($use_ext_htmldtd)
 test $use_ext_htmldtd = "no" && AC_DEFINE(NO_EXTENDED_HTMLDTD)
 
+AC_MSG_CHECKING(if partial-display should be used)
+CF_ARG_DISABLE(partial,
+[  --disable-partial       use partial-display logic],
+	[use_partial_display=$enableval],
+	[use_partial_display=yes])
+AC_MSG_RESULT($use_partial_display)
+test $use_partial_display != no && AC_DEFINE(DISP_PARTIAL)
+
 AC_MSG_CHECKING(if you want to use external commands)
 CF_ARG_ENABLE(externs,
 [  --enable-externs        use external commands],
@@ -715,6 +760,15 @@ if test ".$use_zlib" != ".no" ; then
 	AC_DEFINE(USE_ZLIB)
 fi
 
+AC_MSG_CHECKING(if you want to exclude GOPHER code)
+CF_ARG_DISABLE(gopher,
+[  --disable-gopher  disable GOPHER logic],
+	[use_gopher=yes],
+	[use_gopher=no])
+AC_MSG_RESULT($use_gopher)
+test $use_gopher != "no" && AC_DEFINE(DISABLE_GOPHER)
+
+
 dnl --------------------------------------------------------------------------
 dnl DirEd (directory-editor) options
 dnl --------------------------------------------------------------------------
@@ -817,6 +871,7 @@ AC_OUTPUT(
 	$SUB_MAKEFILE
 	],[
 	if test "$USE_NLS" = yes ; then
+	if test "$use_our_messages" = yes ; then
 		echo creating po/makefile
 		rm -f	po/temp$$
 		sed	-e 's@^.*LYMessages.c@../LYMessages.c@' \
@@ -825,7 +880,9 @@ AC_OUTPUT(
 			po/makefile.in > po/makefile
 		rm -f	po/temp$$
 	fi
+	fi
 	],[
 	USE_NLS=$USE_NLS
+	use_our_messages=$use_our_messages
 	]
 )