about summary refs log tree commit diff stats
path: root/PACKAGE/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'PACKAGE/debian/rules')
-rwxr-xr-xPACKAGE/debian/rules16
1 files changed, 8 insertions, 8 deletions
diff --git a/PACKAGE/debian/rules b/PACKAGE/debian/rules
index 908ed5e0..08cabf63 100755
--- a/PACKAGE/debian/rules
+++ b/PACKAGE/debian/rules
@@ -1,5 +1,9 @@
 #!/usr/bin/make -f
-# $LynxId: rules,v 1.19 2024/01/15 01:16:07 tom Exp $
+# $LynxId: rules,v 1.24 2024/03/14 13:48:36 tom Exp $
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -20,10 +24,6 @@ helpdir		:= $(docdir)/help_dir
 DSTDIR		:= $(CURDIR)/debian/$(PACKAGE)
 DOCDIR		:= $(DSTDIR)$(docdir)
 
-CPPFLAGS	:= $(shell dpkg-buildflags --get CPPFLAGS)
-CFLAGS		:= $(shell dpkg-buildflags --get CFLAGS)
-LDFLAGS		:= $(shell dpkg-buildflags --get LDFLAGS)
-
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
 DEBOP=--enable-debug
 else
@@ -155,15 +155,15 @@ install-indep:
 install-arch:
 	dh_testdir
 	dh_testroot
-	dh_prep -s 
-	dh_installdirs -s
+	dh_prep -a
+	dh_installdirs -a
 
 	$(MAKE) install-full \
 		DESTDIR=$(DSTDIR) \
 		docdir=$(docdir) \
 		helpdir=$(helpdir)
 
-	cd $(DOCDIR) && rm -f COPY*.asc CHANGES 
+	cd $(DOCDIR) && rm -f COPY*.asc CHANGES
 
 # Build architecture-independent files here.
 binary-indep: build install