about summary refs log tree commit diff stats
path: root/076stream.mu
Commit message (Collapse)AuthorAgeFilesLines
* 2778 - fix all layersKartik K. Agaram2016-03-141-41/+0
|
* 2735 - define recipes using 'def'Kartik K. Agaram2016-03-081-4/+4
| | | | | | | | | | | | I'm dropping all mention of 'recipe' terminology from the Readme. That way I hope to avoid further bike-shedding discussions while I very slowly decide on the right terminology with my students. I could be smarter in my error messages and use 'recipe' when code uses it and 'function' otherwise. But what about other words like ingredient? It would all add complexity that I'm not yet sure is worthwhile. But I do want separate experiences for veteran programmers reading about Mu on github and for people learning programming using Mu.
* 2576 - distinguish allocated addresses from othersKartik K. Agaram2016-01-191-8/+8
| | | | | | | | | | | | | | | | This is the one major refinement on the C programming model I'm planning to introduce in mu. Instead of Rust's menagerie of pointer types and static checking, I want to introduce just one new type, and use it to perform ref-counting at runtime. So far all we're doing is updating new's interface. The actual ref-counting implementation is next. One implication: I might sometimes need duplicate implementations for a recipe with allocated vs vanilla addresses of the same type. So far it seems I can get away with just always passing in allocated addresses; the situations when you want to pass an unallocated address to a recipe should be few and far between.
* 2559 - stop using 'next-ingredient' explicitlyKartik K. Agaram2016-01-121-1/+1
| | | | | I still need it in some situations because I have no way to set a non-zero default for an optional ingredient. Open question..
* 2474 - overload 'copy' and 'equal' for textKartik K. Agaram2015-11-221-1/+1
| | | | 2473 was the final bugfix holding this back.
* 2467 - rename 'string' to 'text' everywhereKartik K. Agaram2015-11-211-2/+2
| | | | | | | | Not entirely happy with this. Maybe we'll find a better name. But at least it's an improvement. One part I *am* happy with is renaming string-replace to replace, string-append to append, etc. Overdue, now that we have static dispatch.
* 2460 - headers for remaining recipesKartik K. Agaram2015-11-181-15/+12
|
* 2430 - make room for more transformsKartik K. Agaram2015-11-131-0/+44