about summary refs log tree commit diff stats
path: root/cpp/025name
Commit message (Collapse)AuthorAgeFilesLines
* 1072Kartik K. Agaram2015-04-171-172/+0
|
* 1069 - rename record/field to container/elementKartik K. Agaram2015-04-161-16/+16
| | | | | | | | | This seems more obvious to laypeople. I've also come up with a design for sum types: I'm going to call them exclusive containers. You call 'get' on containers, 'index' on arrays, and 'maybe-convert' on exclusive containers (as well as tagged types, but that's even later).
* 1066 - bugfix: support string literals with colonsKartik K. Agaram2015-04-151-2/+3
|
* 1063 - variable names for surrounding spaces now workKartik K. Agaram2015-04-141-3/+15
| | | | This was a pain to debug.
* 1060Kartik K. Agaram2015-04-141-5/+4
|
* 1055Kartik K. Agaram2015-04-121-1/+1
|
* 1051Kartik K. Agaram2015-04-121-1/+1
|
* 1043 - clean up indent in generated mu.ccKartik K. Agaram2015-04-081-1/+1
|
* 1041 - why was I clearing name assignments?Kartik K. Agaram2015-04-081-2/+0
|
* 1039Kartik K. Agaram2015-04-081-1/+1
|
* 1038 - clean up layer organization a littleKartik K. Agaram2015-04-081-3/+3
| | | | | Things are quite intricate to avoid reloading all recipes before every test. But mu wasn't really intended to sidestep intrinsic intricacy.
* 1034 - more test isolationKartik K. Agaram2015-04-081-1/+1
| | | | The layers are a mess now, but we'll take care of that later.
* 1033 - clear any new name tables created in each testKartik K. Agaram2015-04-081-1/+5
|
* 1017Kartik K. Agaram2015-04-041-2/+8
|
* 1011 - string-equal now workingKartik K. Agaram2015-04-031-1/+1
|
* 1006Kartik K. Agaram2015-04-031-6/+6
|
* 996 - string literalsKartik K. Agaram2015-03-301-0/+1
|
* 985Kartik K. Agaram2015-03-271-13/+16
|
* 973Kartik K. Agaram2015-03-261-2/+1
|
* 968Kartik K. Agaram2015-03-241-1/+1
|
* 966 - c++: starting on default-spaceKartik K. Agaram2015-03-211-6/+7
|
* 963Kartik K. Agaram2015-03-201-1/+11
| | | | Amazing how easy that was.
* 962 - no, not quiteKartik K. Agaram2015-03-201-3/+18
| | | | A big one left: tracking the size of reagents.
* 961 - done converting names?Kartik K. Agaram2015-03-201-2/+46
| | | | | | | | | | | I'm making two changes to how I compute field offsets: a) I just replace offset names up front, before I even manage field names. I don't bother disallowing x:integer and x:offset in the same function. Let's see if that leads us astray. Certainly saves code. b) I don't bother canonizing the first arg of a get since we know it has to have a type that is some number of 'address' followed by a record. Just assume that we have the right number of 'deref's.
* 960Kartik K. Agaram2015-03-201-2/+11
|
* 959Kartik K. Agaram2015-03-201-4/+18
|
* 957 - starting to do name translationKartik K. Agaram2015-03-181-0/+56