about summary refs log tree commit diff stats
path: root/sandbox/008-sandbox-test.mu
Commit message (Collapse)AuthorAgeFilesLines
* 2983 - migrate buttons over to sandbox/Kartik K. Agaram2016-05-191-203/+0
|
* 2954 - bugfix: $systemKartik K. Agaram2016-05-111-1/+6
| | | | The actual fix is in the layer rewriting literal strings.
* 2864 - replace all address:shared with just addressKartik K. Agaram2016-04-241-19/+19
| | | | | | | Now that we no longer have non-shared addresses, we can just always track refcounts for all addresses. Phew!
* 2861 - 'maybe-convert' no longer returns addressKartik K. Agaram2016-04-231-2/+2
|
* 2854 - purge get-address from sandbox/ appKartik K. Agaram2016-04-221-13/+12
|
* 2782 - directly use string literals everywhereKartik K. Agaram2016-03-141-1/+1
|
* 2735 - define recipes using 'def'Kartik K. Agaram2016-03-081-10/+10
| | | | | | | | | | | | I'm dropping all mention of 'recipe' terminology from the Readme. That way I hope to avoid further bike-shedding discussions while I very slowly decide on the right terminology with my students. I could be smarter in my error messages and use 'recipe' when code uses it and 'function' otherwise. But what about other words like ingredient? It would all add complexity that I'm not yet sure is worthwhile. But I do want separate experiences for veteran programmers reading about Mu on github and for people learning programming using Mu.
* 2624Kartik K. Agaram2016-02-011-6/+21
| | | | Reorganize further to make edit/008-sandbox-test more self-contained.
* 2623 - bugfix: editing sandboxesKartik K. Agaram2016-02-011-0/+13
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | If you restore 2 sandboxes, the first render was setting response-starting-row-on-screen on both, without ever rendering a response. If the lower sandbox contained a print and rendered the screen instead of the response, the original response-starting-row-on-screen was never reset. If the process of running the sandboxes caused the lower sandbox's title bar to move below the now-stale response-starting-row-on-screen[1], editing the lower sandbox no longer works. [1] (Either because the upper sandbox prints to screen as well (causing the first F4 to move the lower sandbox down by several lines), or because a fresh sandbox is created with several lines before the first F4 is hit.) Current solution: never set response-starting-row-on-screen during reload (or otherwise when there's no response). This is hard to test right now because 'restore' is not a tested interface, and I can't come up with another situation where the response-starting-row-on-screen goes stale. So I'm now trying to keep all changes to response-starting-row-on-screen close together. Another idea is to add a check that the click row lies below the response-starting row *and* above the start of the next sandbox. (But what if there's no next sandbox?) (This bug is really a regression, introduced last Sep in 2163.)
* 2609 - reuse test-recipe variables in sandbox/ testsKartik K. Agaram2016-01-271-2/+2
| | | | | | | | I'd feared that the refcount errors in the previous commit meant there was a bug in my ref-counting, so I temporarily used new variables rather than reusing existing ones. But it turns out the one remaining place memory corruption can happen is when recipes don't use default-scope and so end up sharing memory. Don't I have a warning for this?
* 2608 - fix-up tests in sandbox/ appKartik K. Agaram2016-01-271-1/+80
| | | | | | | | | | When I first forked it from the edit/ app, I wasn't sure how to deal with changing the recipe side when the only way the program accesses it is with the untestable 'restore' hack. Now we introduce a little hook into event-loop and pass in any updated recipe side directly. In the process I've cleaned up several minor stylistic inconsistencies between edit/ and sandbox/ apps.
* 2590 - support scrolling through sandboxesKartik K. Agaram2016-01-221-1/+1
|
* 2576 - distinguish allocated addresses from othersKartik K. Agaram2016-01-191-9/+9
| | | | | | | | | | | | | | | | This is the one major refinement on the C programming model I'm planning to introduce in mu. Instead of Rust's menagerie of pointer types and static checking, I want to introduce just one new type, and use it to perform ref-counting at runtime. So far all we're doing is updating new's interface. The actual ref-counting implementation is next. One implication: I might sometimes need duplicate implementations for a recipe with allocated vs vanilla addresses of the same type. So far it seems I can get away with just always passing in allocated addresses; the situations when you want to pass an unallocated address to a recipe should be few and far between.
* 2474 - overload 'copy' and 'equal' for textKartik K. Agaram2015-11-221-1/+1
| | | | 2473 was the final bugfix holding this back.
* 2467 - rename 'string' to 'text' everywhereKartik K. Agaram2015-11-211-3/+3
| | | | | | | | Not entirely happy with this. Maybe we'll find a better name. But at least it's an improvement. One part I *am* happy with is renaming string-replace to replace, string-append to append, etc. Overdue, now that we have static dispatch.
* 2428 - sandbox/ working againKartik K. Agaram2015-11-121-6/+4
|
* 2183 - environment + external editor using tmuxKartik K. Agaram2015-09-121-0/+94
Thanks Jack and Caleb Couch for the idea.