summary refs log tree commit diff stats
path: root/setup.py
diff options
context:
space:
mode:
authorhut <hut@lavabit.com>2010-09-16 18:19:46 +0200
committerhut <hut@lavabit.com>2010-09-16 18:19:46 +0200
commit4341846741b6623a1ead43485cfd5cf633453bb6 (patch)
treefdfdd0b13329ad457ad9a6a0c0091019396ae64a /setup.py
parent37a60686b340f030a2fc37e7ac9d19a701de9e6b (diff)
parent0c0849c3d8bf57a8b0d0bd9d6113639c58a28fd2 (diff)
downloadranger-4341846741b6623a1ead43485cfd5cf633453bb6.tar.gz
Merge branch 'master' into cp
Conflicts:
	ranger/__main__.py
	ranger/core/actions.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..587b52c0
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,43 @@
+#!/usr/bin/env python
+# Copyright (C) 2009, 2010  Roman Zimbelmann <romanz@lavabit.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+import distutils.core
+import ranger
+
+if __name__ == '__main__':
+	distutils.core.setup(
+		name='ranger',
+		description='Vim-like file manager',
+		version=ranger.__version__,
+		author=ranger.__author__,
+		author_email=ranger.__email__,
+		license=ranger.__license__,
+		url='http://savannah.nongnu.org/projects/ranger',
+		scripts=['scripts/ranger'],
+		data_files=[('share/man/man1', ['doc/ranger.1'])],
+		package_data={'ranger': ['data/*']},
+		packages=('ranger',
+		          'ranger.api',
+		          'ranger.colorschemes',
+		          'ranger.container',
+		          'ranger.core',
+		          'ranger.defaults',
+		          'ranger.ext',
+		          'ranger.fsobject',
+		          'ranger.gui',
+		          'ranger.gui.widgets',
+		          'ranger.help',
+		          'ranger.shared'))