summary refs log tree commit diff stats
path: root/setup.py
diff options
context:
space:
mode:
authorShadab Zafar <dufferzafar0@gmail.com>2015-06-25 23:40:59 +0530
committerShadab Zafar <dufferzafar0@gmail.com>2015-06-25 23:44:53 +0530
commit8b958c577a7f5f484db42b7c26b0340e14fd9351 (patch)
tree7d332d64df028347f7220e462e9e0cd47056e86e /setup.py
parentdb7c728b71bce950b4683dca16d85fbc55bd2c42 (diff)
downloadranger-8b958c577a7f5f484db42b7c26b0340e14fd9351.tar.gz
Use setuptools if present
The main reason for this is the presence of `develop` command in setuptools.

So by running `sudo python setup.py develop` - ranger gets installed, but you
can easily make changes to the code and won't have to reinstall it.

You can read more about it here:
http://pythonhosted.org//setuptools/setuptools.html#development-mode

It basically links an egg, so I had to add an appropriate line to .gitignore
as well.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1e074f8d..cd3b80de 100755
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,12 @@
 # This file is part of ranger, the console file manager.
 # License: GNU GPL version 3, see the file "AUTHORS" for details.
 
-import distutils.core
+# Setuptools is superior but not available in the stdlib
+try:
+    from setuptools import setup
+except ImportError:
+    from distutils.core import setup
+
 import os.path
 import ranger
 
@@ -11,7 +16,7 @@ def _findall(directory):
             if os.path.isfile(os.path.join(directory, f))]
 
 if __name__ == '__main__':
-    distutils.core.setup(
+    setup(
         name='ranger',
         description='Vim-like file manager',
         long_description=ranger.__doc__,