summary refs log tree commit diff stats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 5 insertions, 16 deletions
diff --git a/setup.py b/setup.py
index ec782794..d8de3130 100755
--- a/setup.py
+++ b/setup.py
@@ -1,18 +1,6 @@
 #!/usr/bin/env python
 # Copyright (C) 2009, 2010, 2011  Roman Zimbelmann <romanz@lavabit.com>
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+# This software is distributed under the terms of the GNU GPL version 3.
 
 import distutils.core
 import ranger
@@ -27,15 +15,16 @@ if __name__ == '__main__':
 		author_email=ranger.__email__,
 		license=ranger.__license__,
 		url='http://savannah.nongnu.org/projects/ranger',
-		scripts=['ranger/data/ranger'],
+		scripts=['scripts/ranger', 'scripts/rifle'],
 		data_files=[('share/man/man1', ['doc/ranger.1'])],
-		package_data={'ranger': ['data/*', 'defaults/rc.conf']},
+		package_data={'ranger': ['data/*', 'config/rc.conf',
+			'config/rifle.conf']},
 		packages=('ranger',
 		          'ranger.api',
 		          'ranger.colorschemes',
 		          'ranger.container',
 		          'ranger.core',
-		          'ranger.defaults',
+		          'ranger.config',
 		          'ranger.ext',
 		          'ranger.fsobject',
 		          'ranger.gui',