summary refs log tree commit diff stats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 1e074f8d..4fbbccba 100755
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,12 @@
 # This file is part of ranger, the console file manager.
 # License: GNU GPL version 3, see the file "AUTHORS" for details.
 
-import distutils.core
+# Setuptools is superior but not available in the stdlib
+try:
+    from setuptools import setup
+except ImportError:
+    from distutils.core import setup
+
 import os.path
 import ranger
 
@@ -11,7 +16,7 @@ def _findall(directory):
             if os.path.isfile(os.path.join(directory, f))]
 
 if __name__ == '__main__':
-    distutils.core.setup(
+    setup(
         name='ranger',
         description='Vim-like file manager',
         long_description=ranger.__doc__,
@@ -27,7 +32,7 @@ if __name__ == '__main__':
                  'doc/rifle.1']),
             ('share/doc/ranger',
                 ['README.md',
-                 'CHANGELOG',
+                 'CHANGELOG.md',
                  'HACKING.md',
                  'doc/colorschemes.txt']),
             ('share/doc/ranger/config/colorschemes',