about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorComradeCrow <comradecrow@vivaldi.net>2023-04-01 01:48:32 -0700
committerComradeCrow <comradecrow@vivaldi.net>2023-04-01 01:48:32 -0700
commit1082974bf046a94b4a52df6e8b3b3649a5bb85d6 (patch)
tree61b9c5e1271280405c72f0526e300d5a8c4e0783 /CMakeLists.txt
parent6cbff5d60cb708eb7f1eb0a598a6bb99d4b3a9e7 (diff)
downloadytcpp-1082974bf046a94b4a52df6e8b3b3649a5bb85d6.tar.gz
minor update
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1702629..4500127 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,8 +17,6 @@ FetchContent_Declare(cpr GIT_REPOSITORY https://github.com/libcpr/cpr.git
                          GIT_TAG c4713a704ca12237485ecbfec185f76c2a81bd09)
 FetchContent_MakeAvailable(cpr)
 
-include(FetchContent)
-
 FetchContent_Declare(ftxui
   GIT_REPOSITORY https://github.com/ArthurSonzogni/ftxui.git
   GIT_TAG v4.0.0
@@ -33,6 +31,8 @@ endif()
 FetchContent_Declare(json URL https://github.com/nlohmann/json/releases/download/v3.11.2/json.tar.xz)
 FetchContent_MakeAvailable(json)
 
+find_package(SQLite3 REQUIRED)
+
 add_executable(${PROJECT_NAME} src/main.cpp)
 target_include_directories(${PROJECT_NAME} PRIVATE src)
 
@@ -42,4 +42,5 @@ target_link_libraries(${PROJECT_NAME}
     PRIVATE ftxui::dom
     PRIVATE ftxui::component
     PRIVATE nlohmann_json::nlohmann_json
+    PRIVATE SQLite::SQLite3
 )