about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorComradeCrow <comradecrow@vivaldi.net>2023-04-14 21:25:55 -0700
committerComradeCrow <comradecrow@vivaldi.net>2023-04-14 21:25:55 -0700
commit44803a87a143c8a94d5dbc10e0942d947a12c023 (patch)
treee164c2415635444e26e8f852ec48b238fcf08be3 /CMakeLists.txt
parent87d0da3a93b7f596ecfd62886efb2f1d965be0dd (diff)
downloadytcpp-44803a87a143c8a94d5dbc10e0942d947a12c023.tar.gz
failure to get pybind to work
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf5b4da..f6a31de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,7 @@ project(ytcpp
 )
 
 set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/cmake)
 
 if(WIN32) # Install dlls in the same directory as the executable on Windows
     set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
@@ -37,6 +38,8 @@ find_package(SQLite3 REQUIRED)
 # find_package(pybind11 REQUIRED)
 add_subdirectory(extern/pybind11)
 
+find_package(Ytdlp REQUIRED RUNTIME)
+
 add_executable(${PROJECT_NAME} src/main.cpp)
 target_include_directories(${PROJECT_NAME} PRIVATE src)