about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6a31de..b5fbdca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,12 +29,14 @@ if(NOT ftxui_POPULATED)
   add_subdirectory(${ftxui_SOURCE_DIR} ${ftxui_BINARY_DIR} EXCLUDE_FROM_ALL)
 endif()
 
-FetchContent_Declare(json URL https://github.com/nlohmann/json/releases/download/v3.11.2/json.tar.xz)
+FetchContent_Declare(json URL https://github.com/nlohmann/json/releases/download/v3.11.2/json.tar.xz) ##https://github.com/nlohmann/json/releases/latest/download/json.tar.xz
 
 FetchContent_MakeAvailable(json cpr)
 
 find_package(SQLite3 REQUIRED)
 
+## find_package(PCAP REQUIRED)
+
 # find_package(pybind11 REQUIRED)
 add_subdirectory(extern/pybind11)
 
@@ -50,5 +52,6 @@ target_link_libraries(${PROJECT_NAME}
     PRIVATE ftxui::component
     PRIVATE nlohmann_json::nlohmann_json
     PRIVATE SQLite::SQLite3
+    ## ${PCAP_LIBRARY}
     PRIVATE pybind11::embed
 )