about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 52a19dc1..63eae494 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,8 +66,8 @@ AC_ARG_WITH([xscreensaver],
     [AS_HELP_STRING([--with-xscreensaver], [use libXScrnSaver to determine idle time])])
 AC_ARG_WITH([themes],
     [AS_HELP_STRING([--with-themes[[=PATH]]], [install themes (default yes)])])
-AC_ARG_ENABLE([icons],
-    [AS_HELP_STRING([--enable-icons], [enable GTK tray icons])])
+AC_ARG_ENABLE([icons-and-clipboard],
+    [AS_HELP_STRING([--enable-icons-and-clipboard], [enable GTK tray icons and clipboard paste support])])
 
 ### plugins
 
@@ -172,12 +172,12 @@ PKG_CHECK_MODULES([curl], [libcurl], [],
     [AC_CHECK_LIB([curl], [main], [],
         [AC_MSG_ERROR([libcurl is required for profanity])])])
 
-AS_IF([test "x$enable_icons" != xno],
+AS_IF([test "x$enable_icons_and_clipboard" != xno],
     [PKG_CHECK_MODULES([GTK], [gtk+-2.0 >= 2.24.10],
         [AC_DEFINE([HAVE_GTK], [1], [libgtk module])],
-        [AS_IF([test "x$enable_icons" = xyes],
+        [AS_IF([test "x$enable_icons_and_clipboard" = xyes],
             [AC_MSG_ERROR([gtk+-2.0 or higher is required for icons])],
-            [AC_MSG_NOTICE([gtk+-2.0 not found, icons not enabled])])])])
+            [AC_MSG_NOTICE([gtk+-2.0 not found, icons and clipboard not enabled])])])])
 
 AS_IF([test "x$PLATFORM" = xosx],
     [AC_CHECK_FILE([/usr/local/opt/readline/lib],