about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/clojure.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/home/includes/clojure.nix')
-rw-r--r--nix-conf/home/includes/clojure.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/nix-conf/home/includes/clojure.nix b/nix-conf/home/includes/clojure.nix
new file mode 100644
index 0000000..3681e8b
--- /dev/null
+++ b/nix-conf/home/includes/clojure.nix
@@ -0,0 +1,18 @@
+{ config, pkgs, lib, isDarwin, isLinux, ... }:
+let
+  inherit (lib) optionals;
+in
+{
+  home.packages = with pkgs; [
+    babashka
+    clj-kondo
+    clojure
+    clojure-lsp
+    jet
+    maven
+    neil
+  ]
+  ++ optionals stdenv.isDarwin [ (leiningen.override { jdk = jdk8; }) ]
+  ++ optionals stdenv.isLinux [ leiningen ];
+}
+