about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/dev-common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/home/includes/dev-common.nix')
-rw-r--r--nix-conf/home/includes/dev-common.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix-conf/home/includes/dev-common.nix b/nix-conf/home/includes/dev-common.nix
new file mode 100644
index 0000000..da3665c
--- /dev/null
+++ b/nix-conf/home/includes/dev-common.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, ... }:
+{
+
+  imports = [
+    ./common.nix
+    ./clojure.nix
+  ];
+
+  home.packages = with pkgs; [
+    docker
+    docker-compose
+    gopass-jsonapi
+    mpv
+    mu
+    neovim
+  ];
+
+  programs.tmux = {
+    enable = true;
+    terminal = "screen-256color";
+    #tmuxp.enable = true;
+    extraConfig = ''
+      set-option -g status-bg '#666666'
+      set-option -g status-fg '#aaaaaa'
+      set-option -g status-left-length 50
+      set-option -g status-right " #(date ''\'+%a, %b %d - %I:%M''\') "
+    '';
+  };
+
+}
+