about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/linux-dev.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/home/includes/linux-dev.nix')
-rw-r--r--nix-conf/home/includes/linux-dev.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nix-conf/home/includes/linux-dev.nix b/nix-conf/home/includes/linux-dev.nix
new file mode 100644
index 0000000..b2c6885
--- /dev/null
+++ b/nix-conf/home/includes/linux-dev.nix
@@ -0,0 +1,35 @@
+{ config, pkgs, ... }:
+{
+  imports = [
+    ./dev-common.nix
+  ];
+  #services.emacs.package = pkgs.emacsUnstable;
+
+  nixpkgs.overlays = [
+    (import (builtins.fetchTarball {
+      url = https://github.com/nix-community/emacs-overlay/archive/master.tar.gz;
+    }))
+  ];
+  programs.emacs = {
+    enable = true;
+    #package = pkgs.emacsGcc;
+    package = pkgs.emacs28NativeComp;
+    extraPackages = (epkgs: [ epkgs.vterm ] );
+  };
+
+  home.packages = with pkgs; [
+    docker
+    docker-compose
+    gcc
+    gnumake
+    mpv
+    mu
+    notmuch
+    nix
+    protonmail-bridge
+    protonvpn-cli
+    youtube-dl
+  ];
+
+}
+