about summary refs log tree commit diff stats
path: root/nix-conf/home/otm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/home/otm.nix')
-rw-r--r--nix-conf/home/otm.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nix-conf/home/otm.nix b/nix-conf/home/otm.nix
index c79437b..1065852 100644
--- a/nix-conf/home/otm.nix
+++ b/nix-conf/home/otm.nix
@@ -12,6 +12,26 @@
   home.username = "djm";
   home.homeDirectory = "/Users/djm";
 
+  programs.git = {
+    signing.signByDefault = lib.mkForce false;
+    includes = [
+      { path = "~/.gitconfig-personal"; condition = "gitdir:~/src/personal/"; }
+      { contents = { commit.gpg = true; }; condition = "gitdir:~/src/personal/"; }
+    ];
+    extraConfig = {
+      github.user = "david-morgan-otm";
+    };
+    ignores = [
+      ".envrc"
+      ".clj-kondo"
+      "shell.nix"
+      ".direnv"
+      ".dir-locals.el"
+      "browser-tests/package-lock.json"
+      "resources/react-app/package-lock.json"
+      "resources/next/package-lock.json"
+    ];
+  };
   programs.ssh.matchBlocks = {
     "github.com" = lib.mkForce {
       hostname = "github.com";