about summary refs log tree commit diff stats
path: root/nix-conf/home/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/home/zsh.nix')
-rw-r--r--nix-conf/home/zsh.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix-conf/home/zsh.nix b/nix-conf/home/zsh.nix
index 8118eb9..ce5b9d5 100644
--- a/nix-conf/home/zsh.nix
+++ b/nix-conf/home/zsh.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 {
   home.packages = with pkgs; [
@@ -18,7 +18,7 @@
     nix-direnv.enable = true;
   };
   programs.keychain = {
-    enable = true;
+    enable = lib.mkIf pkgs.stdenv.isLinux true;
     agents = [ "ssh" "gpg"];
     keys = [ "id_rsa" "id_ed25519" "C171251002C200F2" ];
   #  extraFlags = [ "--quiet" "--ignore-missing" ];