about summary refs log tree commit diff stats
path: root/nix-conf/machines/edrahil/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/machines/edrahil/hardware-configuration.nix')
-rw-r--r--nix-conf/machines/edrahil/hardware-configuration.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/nix-conf/machines/edrahil/hardware-configuration.nix b/nix-conf/machines/edrahil/hardware-configuration.nix
index f67b9f4..e20c7a7 100644
--- a/nix-conf/machines/edrahil/hardware-configuration.nix
+++ b/nix-conf/machines/edrahil/hardware-configuration.nix
@@ -1,9 +1,12 @@
-{ modulesPath, ... }:
-{
+{ modulesPath, ... }: {
   imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
   boot.loader.grub.device = "/dev/sda";
-  boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "vmw_pvscsi" "xen_blkfront" ];
+  boot.initrd.availableKernelModules =
+    [ "ata_piix" "uhci_hcd" "vmw_pvscsi" "xen_blkfront" ];
   boot.initrd.kernelModules = [ "nvme" ];
-  fileSystems."/" = { device = "/dev/sda1"; fsType = "ext4"; };
-  
+  fileSystems."/" = {
+    device = "/dev/sda1";
+    fsType = "ext4";
+  };
+
 }