about summary refs log tree commit diff stats
path: root/nix-conf/machines/egalmoth/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/machines/egalmoth/configuration.nix')
-rw-r--r--nix-conf/machines/egalmoth/configuration.nix54
1 files changed, 25 insertions, 29 deletions
diff --git a/nix-conf/machines/egalmoth/configuration.nix b/nix-conf/machines/egalmoth/configuration.nix
index bb9e03f..dbdce96 100644
--- a/nix-conf/machines/egalmoth/configuration.nix
+++ b/nix-conf/machines/egalmoth/configuration.nix
@@ -1,14 +1,11 @@
 { config, pkgs, lib, ... }:
 
 {
-  imports =
-    [
-      ./hardware-configuration.nix
-    ];
+  imports = [ ./hardware-configuration.nix ];
 
   boot.loader.systemd-boot.enable = true;
   boot.loader.efi.canTouchEfiVariables = true;
-  boot.kernelParams = ["intel_pstate=enable"];
+  boot.kernelParams = [ "intel_pstate=enable" ];
   powerManagement = {
     enable = true;
     #cpuFreqGovernor = "powersave";
@@ -82,11 +79,8 @@
   services.printing.enable = true;
   services.printing.drivers = [ pkgs.gutenprint pkgs.hplipWithPlugin ];
 
-  nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
-    "corefonts"
-    "hplip"
-    "zoom"
-  ];
+  nixpkgs.config.allowUnfreePredicate = pkg:
+    builtins.elem (lib.getName pkg) [ "corefonts" "hplip" "zoom" ];
 
   hardware.sane.enable = true;
 
@@ -119,24 +113,28 @@
     pulse.enable = true;
   };
 
-  users.users.djm =
-   { isNormalUser = true;
-     description = "David Morgan";
-     extraGroups = [ "wheel" "networkmanager" "scanner" "lp" "plocate" "cdrom" "disk" ];
-     shell = pkgs.zsh;
-     openssh.authorizedKeys.keys = [
+  users.users.djm = {
+    isNormalUser = true;
+    description = "David Morgan";
+    extraGroups =
+      [ "wheel" "networkmanager" "scanner" "lp" "plocate" "cdrom" "disk" ];
+    shell = pkgs.zsh;
+    openssh.authorizedKeys.keys = [
       "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCurCpxZCHtByB5wXzsjTXwMyDSB4+B8rq5XY6EGss58NwD8jc5cII4i+QUbCOGTiAggSZUSC9YIP24hjpOeNT/IYs5m7Qn1B9MtBAiUSrIYew8eDwnMLlPzN+k2x9zCrJeCHIvGJaFHPXTh1Lf5Jt2fPVGW9lksE/XUVOe6ht4N/b+nqqszXFhc8Ug6le2bC1YeTCVEf8pjlh/I7DkDBl6IB8uEXc3X2vxxbV0Z4vlBrFkkAywcD3j5VlS/QYfBr4BICNmq/sO3fMkbMbtAPwuFxeL4+h6426AARQZiSS0qVEc8OoFRBVx3GEH5fqVAWfB1geyLzei22HbjUcT9+xN davidmo@gendros"
       "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIK9UDTaVnUOU/JknrNdihlhhGOk53LmHq9I1ASri3aga djm@gaius"
-     ];
-   };
-   security.sudo.extraConfig = ''
-     djm ALL=(ALL) NOPASSWD: ALL
-   '';
-   security.doas = {
-     enable = true;
-     extraRules = [ { users = [ "djm" ]; noPass = true; keepEnv = true; } ];
-   };
-
+    ];
+  };
+  security.sudo.extraConfig = ''
+    djm ALL=(ALL) NOPASSWD: ALL
+  '';
+  security.doas = {
+    enable = true;
+    extraRules = [{
+      users = [ "djm" ];
+      noPass = true;
+      keepEnv = true;
+    }];
+  };
 
   services.locate = {
     enable = true;
@@ -178,9 +176,7 @@
   ];
   programs.nix-ld.enable = true;
 
-  programs.nix-ld.libraries = with pkgs; [
-    xorg.libxcb
-  ];
+  programs.nix-ld.libraries = with pkgs; [ xorg.libxcb ];
 
   fonts.packages = with pkgs; [
     corefonts