summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBen Morrison <ben@gbmor.dev>2020-01-20 19:28:09 -0500
committerBen Morrison <ben@gbmor.dev>2020-01-20 19:28:09 -0500
commit4c1640af865a96a59bdd7a084f6c5acf03112025 (patch)
treec5014676395a3e743a60138148239e6940ba6f92 /Cargo.toml
parent2f29cf60370d4e0c9d2806627147179c8ddf06d2 (diff)
downloadclinte-4c1640af865a96a59bdd7a084f6c5acf03112025.tar.gz
updated deps + added release profile to Cargo.toml
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a722af2..67b8146 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,4 +17,13 @@ users = "^0.9"
 [dependencies.clap]
 version = "^2.33"
 default-features = false
-features = [ "suggestions", "color" ]
\ No newline at end of file
+features = [ "suggestions", "color" ]
+
+[profile.release]
+opt-level = 3
+debug = false
+lto = true
+debug-assertions = false
+panic = 'abort'
+incremental = true
+overflow-checks = false