about summary refs log tree commit diff stats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5bac36b..37b6eb1 100644
--- a/meson.build
+++ b/meson.build
@@ -14,10 +14,19 @@ if fs.exists('raylib/libraylib.a') == true
 else
     error('raylib failed to compile. Check meson-logs to see what went wrong.')
 endif
+
+Raylib_Include = include_directories('raylib/src')
+
+# Install launcher if flatpak
+if get_option('build_flatpak') == true
+    install_data('src/launch.sh', install_dir : 'bin')
+endif
+
 X11_Dep = dependency('x11')
 Threads_Dep = dependency('threads')
 GL_Dep = dependency('gl')
 
 Sources = ['src/main.c', 'src/enemy.c', 'src/ball.c', 'src/title.c']
 
-executable('pong', Sources, dependencies : [X11_Dep, Threads_Dep, GL_Dep])
\ No newline at end of file
+executable('pong', Sources, dependencies : [X11_Dep, Threads_Dep, GL_Dep], install : true, install_dir : 'Pong', include_directories : Raylib_Include)
+install_subdir('resources', install_dir : 'Pong')
\ No newline at end of file