about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2014-04-17 12:35:09 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2014-04-17 12:35:09 +0300
commit0c1092fd30984918e6c70ccdc3b6ba5f79b08f57 (patch)
treeba3f36e2ca4df66688d1c244acfa28ca5e807eef /Makefile.am
parentaa6e2284fcfdc75ef457f3e6266e896633ef3d34 (diff)
downloadprofani-tty-0c1092fd30984918e6c70ccdc3b6ba5f79b08f57.tar.gz
autotools: added EXTRA_DIST
Now sources can be distributed with `make dist-bzip2` command, so no
need to make tarball manually. Current patch takes into account the
status (release or development) and puts .git/HEAD, .git/index to
tarball if necessary.

Unfortunately, current scripts don't add any information about
development status to the version string. Therefore,
profanity-0.5.0.tar.bz2 is got regardless of development or release
status.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index f9d04fde..2db0ef1f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,15 +90,9 @@ otr3_sources = \
 otr4_sources = \
 	src/otr/otrlib.h src/otr/otrlibv4.c src/otr/otr.h src/otr/otr.c
 
-themes_sources = \
-	themes/aqua \
-	themes/boothj5 \
-	themes/hacker \
-	themes/headache \
-	themes/original \
-	themes/redsplash \
-	themes/whiteness \
-	themes/yellowsplash
+themes_sources = themes/*
+
+man_sources = docs/profanity.1
 
 if BUILD_OTR
 if BUILD_OTR3
@@ -126,9 +120,13 @@ check_PROGRAMS = tests/testsuite
 tests_testsuite_SOURCES = $(tests_sources)
 tests_testsuite_LDADD = -lcmocka
 
-man_MANS = docs/profanity.1
+man_MANS = $(man_sources)
+
+EXTRA_DIST = $(man_sources) $(themes_sources)
 
 if INCLUDE_GIT_VERSION
+EXTRA_DIST += .git/HEAD .git/index
+
 $(git_include).in: .git/HEAD .git/index
 	rm -f $@
 	echo "#ifndef PROF_GIT_BRANCH" >> $@