about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2012-07-02 00:36:30 +0100
committerJames Booth <boothj5@gmail.com>2012-07-02 00:36:30 +0100
commit11066f204b327dfa1d741d2127b4c2405bf1fb0f (patch)
tree79f7ddb011542a3f5ce1e238a9294870efbf5a32 /Makefile.am
parent28f5cdf786774cf683821012be36605cbcab0893 (diff)
downloadprofani-tty-11066f204b327dfa1d741d2127b4c2405bf1fb0f.tar.gz
Set compiler, preprocessor flags in configure.ac
Picked up and used in Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fc91e46..d86c7854 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
 CFLAGS = -O3 -Werror -Wall -Wextra -Wno-unused-parameter -Wno-unused-but-set-variable \
-	-Wno-unused-result -lncurses -lstrophe -lxml2 -lexpat -lssl -lresolv \
-		`pkg-config --libs --cflags glib-2.0` `pkg-config --libs --cflags libnotify`
-
+	-Wno-unused-result $(NCURSES_CFLAGS) $(NCURSES_LIBS) -lstrophe -lxml2 -lexpat \
+	$(OPENSSL_CFLAGS) $(OPENSSL_LIBS) -lresolv $(GLIB_CFLAGS) $(GLIB_LIBS) \
+	$(NOTIFY_CFLAGS) $(NOTIFY_LIBS)
 
 bin_PROGRAMS = profanity
 profanity_SOURCES = src/command.c src/contact.c src/history.c src/jabber.h \