about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-07-02 19:20:50 +0100
committerJames Booth <boothj5@gmail.com>2015-07-02 19:20:50 +0100
commit1329fe14ecf9bf9fb2991f3c7784f071bae851f3 (patch)
tree52d11d0662dd41a847e7a36f6c67459e03d329c8 /Makefile.am
parent6c668bce8861c24a4fd1e9d238798efb1dbd31e4 (diff)
downloadprofani-tty-1329fe14ecf9bf9fb2991f3c7784f071bae851f3.tar.gz
Suppress all compile warning when building unit tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0486982d..bcae2923 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,6 +156,7 @@ endif
 TESTS = tests/unittests/unittests tests/functionaltests/functionaltests
 check_PROGRAMS = tests/unittests/unittests tests/functionaltests/functionaltests
 tests_unittests_unittests_SOURCES = $(unittest_sources)
+tests_unittests_unittests_CFLAGS = -w
 tests_unittests_unittests_LDADD = -lcmocka
 tests_functionaltests_functionaltests_SOURCES = $(functionaltest_sources)
 tests_functionaltests_functionaltests_CFLAGS = -I/usr/include/tcl8.6 -I/usr/include/tcl8.5