about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2012-07-01 14:52:45 +0100
committerJames Booth <boothj5@gmail.com>2012-07-01 14:52:45 +0100
commit2655d9e8fad38acd4ce7388c0ba3eaaa976d6940 (patch)
tree91f91f42d6ec489b4b0572cc248344e7b3f55efc /Makefile.am
parent30ca6cac3d7f86e4a43410ba361793cd99d97a10 (diff)
downloadprofani-tty-2655d9e8fad38acd4ce7388c0ba3eaaa976d6940.tar.gz
Moved config.h to source folder
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..0fc91e46
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,14 @@
+CFLAGS = -O3 -Werror -Wall -Wextra -Wno-unused-parameter -Wno-unused-but-set-variable \
+	-Wno-unused-result -lncurses -lstrophe -lxml2 -lexpat -lssl -lresolv \
+		`pkg-config --libs --cflags glib-2.0` `pkg-config --libs --cflags libnotify`
+
+
+bin_PROGRAMS = profanity
+profanity_SOURCES = src/command.c src/contact.c src/history.c src/jabber.h \
+	src/preferences.c src/prof_autocomplete.c src/status_bar.c src/util.h \
+	src/command.h src/contact.h src/history.h src/log.c src/preferences.h \
+	src/prof_autocomplete.h src/title_bar.c src/windows.c src/common.c \
+	src/contact_list.c src/input_win.c src/log.h src/profanity.c \
+	src/prof_history.c src/ui.h src/common.h src/ contact_list.h src/jabber.c \
+	src/main.c src/profanity.h src/prof_history.h src/util.c
+
a> 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164