about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-03-08 18:12:50 +0000
committerJames Booth <boothj5@gmail.com>2015-03-08 18:12:50 +0000
commit2e493112bb6cb7a6b2ca21042d84b5c98db33460 (patch)
treef998e558de333acad317b68293be7c0ea0efdad8 /Makefile.am
parent2112ddea65b076dafc08fb0b5a58ca57f65a6066 (diff)
parent7638f379cac3869abdd8530faa09cc7481e99ec6 (diff)
downloadprofani-tty-2e493112bb6cb7a6b2ca21042d84b5c98db33460.tar.gz
Merge branch 'master' into readline
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 300116b1..cd708a13 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,7 @@ tests_sources = \
 	src/roster_list.c src/roster_list.h \
 	src/xmpp/xmpp.h src/xmpp/form.c \
 	src/ui/ui.h \
+	src/otr/otr.h \
 	src/command/command.h src/command/command.c \
 	src/command/commands.h src/command/commands.c \
 	src/tools/parser.c \
@@ -61,7 +62,6 @@ tests_sources = \
 	src/ui/titlebar.h src/ui/statusbar.h src/ui/inputwin.h \
 	src/server_events.c src/server_events.h \
 	tests/xmpp/stub_xmpp.c \
-	tests/otr/stub_otr.c \
 	tests/ui/stub_ui.c \
 	tests/log/stub_log.c \
 	tests/config/stub_accounts.c \
@@ -101,6 +101,9 @@ otr3_sources = \
 otr4_sources = \
 	src/otr/otrlib.h src/otr/otrlibv4.c src/otr/otr.h src/otr/otr.c
 
+otr_test_sources = \
+	tests/otr/stub_otr.c
+
 themes_sources = themes/*
 
 script_sources = bootstrap.sh configure-debug install-all.sh
@@ -108,6 +111,7 @@ script_sources = bootstrap.sh configure-debug install-all.sh
 man_sources = docs/profanity.1
 
 if BUILD_OTR
+tests_sources += $(otr_test_sources)
 if BUILD_OTR3
 core_sources += $(otr3_sources)
 endif
181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216