about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2022-06-28 21:14:27 +0200
committerGitHub <noreply@github.com>2022-06-28 21:14:27 +0200
commit5fabca1e3746634eed2be3244313af173c1b6a7d (patch)
tree5f47bdfe294d54e0b23b897a541cbcfb3c77b37a /Makefile.am
parente8ae8257095d012e848b71e50269300644c24a12 (diff)
parent974f21efdc1e97902633df0b0eae5f0e855e27fa (diff)
downloadprofani-tty-5fabca1e3746634eed2be3244313af173c1b6a7d.tar.gz
Merge pull request #1727 from profanity-im/log-chatlog-split
Split chatlog and log functions in separate files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e35a518..6c1d88c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
 core_sources = \
 	src/xmpp/contact.c src/xmpp/contact.h \
 	src/log.c src/common.c \
+	src/chatlog.c src/chatlog.h \
 	src/database.h src/database.c \
 	src/log.h src/profanity.c src/common.h \
 	src/profanity.h src/xmpp/chat_session.c \
@@ -123,6 +124,7 @@ unittest_sources = \
 	tests/unittests/xmpp/stub_message.c \
 	tests/unittests/ui/stub_ui.c tests/unittests/ui/stub_ui.h \
 	tests/unittests/log/stub_log.c \
+	tests/unittests/chatlog/stub_chatlog.c \
 	tests/unittests/database/stub_database.c \
 	tests/unittests/config/stub_accounts.c \
 	tests/unittests/config/stub_cafile.c \