about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2020-12-09 08:09:09 +0100
committerGitHub <noreply@github.com>2020-12-09 08:09:09 +0100
commit7a319df6c80c472adcf416c8737e7b156854352b (patch)
tree0bf423e2541b4b5f21a747d4cd88889feadaccab /Makefile.am
parentf023d56b02eec67ea357a85d7f8ec325f87622e3 (diff)
parentd7848e38bc2d916f88e889352f337a5c617fb26d (diff)
downloadprofani-tty-7a319df6c80c472adcf416c8737e7b156854352b.tar.gz
Merge pull request #1375 from wstrm/feature/omemo-sendfile
Send and retrieve encrypted files when using OMEMO
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a4d8ffb..d40494d1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,8 +41,12 @@ core_sources = \
 	src/command/cmd_ac.h src/command/cmd_ac.c \
 	src/tools/parser.c \
 	src/tools/parser.h \
+	src/tools/http_common.c \
+	src/tools/http_common.h \
 	src/tools/http_upload.c \
 	src/tools/http_upload.h \
+	src/tools/http_download.c \
+	src/tools/http_download.h \
 	src/tools/bookmark_ignore.c \
 	src/tools/bookmark_ignore.h \
 	src/tools/autocomplete.c src/tools/autocomplete.h \
@@ -119,6 +123,8 @@ unittest_sources = \
 	tests/unittests/database/stub_database.c \
 	tests/unittests/config/stub_accounts.c \
 	tests/unittests/tools/stub_http_upload.c \
+	tests/unittests/tools/stub_http_download.c \
+	tests/unittests/tools/stub_aesgcm_download.c \
 	tests/unittests/helpers.c tests/unittests/helpers.h \
 	tests/unittests/test_form.c tests/unittests/test_form.h \
 	tests/unittests/test_common.c tests/unittests/test_common.h \
@@ -189,7 +195,8 @@ otr4_sources = \
 
 omemo_sources = \
 	src/omemo/omemo.h src/omemo/omemo.c src/omemo/crypto.h src/omemo/crypto.c \
-	src/omemo/store.h src/omemo/store.c src/xmpp/omemo.h src/xmpp/omemo.c
+	src/omemo/store.h src/omemo/store.c src/xmpp/omemo.h src/xmpp/omemo.c \
+	src/tools/aesgcm_download.h src/tools/aesgcm_download.c
 
 omemo_unittest_sources = \
 	tests/unittests/omemo/stub_omemo.c