about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2013-12-14 16:07:57 +0000
committerJames Booth <boothj5@gmail.com>2013-12-14 16:07:57 +0000
commit7f7973f9a72b2b6c7fe39cc39929f779d1662a69 (patch)
treee92b614c8980c538ea21473e83a9b42371d56e25 /Makefile.am
parent107fdd355e487793e53799ce3ebed0659263a2f7 (diff)
downloadprofani-tty-7f7973f9a72b2b6c7fe39cc39929f779d1662a69.tar.gz
Moved common tests to cmocka
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e001a87e..8ca2123c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,7 +80,9 @@ test_sources = \
 	src/config/accounts.c src/config/accounts.h \
 	src/config/preferences.c src/config/preferences.h \
 	src/config/theme.c src/config/theme.h \
-	tests/test_command.c
+    tests/test_common.c \
+	tests/test_command.c \
+    tests/testsuite.c
 
 main_source = src/main.c
 
@@ -101,6 +103,6 @@ profanity_SOURCES = $(with_git_sources) $(main_source)
 TESTS = tests/testsuite
 check_PROGRAMS = tests/testsuite
 tests_testsuite_SOURCES = $(tests_with_git_sources)
-tests_testsuite_LDADD = -lheadunit -lstdc++ -lcmocka
+tests_testsuite_LDADD = -lcmocka
 
 man_MANS = docs/profanity.1