about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-05-17 01:11:03 +0100
committerJames Booth <boothj5@gmail.com>2015-05-17 01:11:03 +0100
commit97c5072f56b992d3bf2e4c3550a8010f9638b80a (patch)
tree7fa409d9cb275422c296acf5a0f204d1757c5eb3 /Makefile.am
parentaeffca496c338e91cacb4af1ebf0d8ca3160bf31 (diff)
downloadprofani-tty-97c5072f56b992d3bf2e4c3550a8010f9638b80a.tar.gz
Added stabber testsuite
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 48 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 372b60f3..e3ffc654 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,7 @@ core_sources = \
 	src/config/preferences.c src/config/preferences.h \
 	src/config/theme.c src/config/theme.h
 
-tests_sources = \
+test_sources = \
 	src/contact.c src/contact.h src/common.c \
 	src/log.h src/profanity.c src/common.h \
 	src/profanity.h src/chat_session.c \
@@ -94,6 +94,45 @@ tests_sources = \
 	tests/test_chat_session.c tests/test_chat_session.h \
 	tests/testsuite.c
 
+stabbertest_sources = \
+	src/contact.c src/contact.h src/log.c src/common.c \
+	src/log.h src/profanity.c src/common.h \
+	src/profanity.h src/chat_session.c \
+	src/chat_session.h src/muc.c src/muc.h src/jid.h src/jid.c \
+	src/chat_state.h src/chat_state.c \
+	src/resource.c src/resource.h \
+	src/roster_list.c src/roster_list.h \
+	src/xmpp/xmpp.h src/xmpp/capabilities.c src/xmpp/connection.c \
+	src/xmpp/iq.c src/xmpp/message.c src/xmpp/presence.c src/xmpp/stanza.c \
+	src/xmpp/stanza.h src/xmpp/message.h src/xmpp/iq.h src/xmpp/presence.h \
+	src/xmpp/capabilities.h src/xmpp/connection.h \
+	src/xmpp/roster.c src/xmpp/roster.h \
+	src/xmpp/bookmark.c src/xmpp/bookmark.h \
+	src/xmpp/form.c src/xmpp/form.h \
+	src/event/server_events.c src/event/server_events.h \
+	src/event/client_events.c src/event/client_events.h \
+	src/event/ui_events.c src/event/ui_events.h \
+	src/ui/ui.h src/ui/window.c src/ui/window.h \
+	src/ui/windows.c src/ui/windows.h \
+	src/ui/buffer.c src/ui/buffer.h \
+	src/ui/statusbar.c src/ui/statusbar.h \
+	src/ui/inputwin.c src/ui/inputwin.h \
+	src/command/command.h src/command/command.c \
+	src/command/commands.h src/command/commands.c \
+	src/tools/parser.c \
+	src/tools/parser.h \
+	src/tools/p_sha1.h src/tools/p_sha1.c \
+	src/tools/autocomplete.c src/tools/autocomplete.h \
+	src/tools/tinyurl.c src/tools/tinyurl.h \
+	src/config/accounts.c src/config/accounts.h \
+	src/config/account.c src/config/account.h \
+	src/config/preferences.c src/config/preferences.h \
+	src/config/theme.c src/config/theme.h \
+	stabbertests/ui/stub_ui.c \
+	stabbertests/proftest.c stabbertests/proftest.h \
+	stabbertests/test_connect.c stabbertests/test_connect.h \
+	stabbertests/testsuite.c
+
 main_source = src/main.c
 
 git_include = src/gitversion.h
@@ -114,12 +153,14 @@ script_sources = bootstrap.sh configure-debug install-all.sh
 man_sources = docs/profanity.1
 
 if BUILD_OTR
-tests_sources += $(otr_test_sources)
+test_sources += $(otr_test_sources)
 if BUILD_OTR3
 core_sources += $(otr3_sources)
+stabbertest_sources += $(otr3_sources)
 endif
 if BUILD_OTR4
 core_sources += $(otr4_sources)
+stabbertest_sources += $(otr4_sources)
 endif
 endif
 
@@ -133,10 +174,12 @@ if INCLUDE_GIT_VERSION
 BUILT_SOURCES = $(git_include)
 endif
 
-TESTS = tests/testsuite
-check_PROGRAMS = tests/testsuite
-tests_testsuite_SOURCES = $(tests_sources)
+TESTS = tests/testsuite stabbertests/testsuite
+check_PROGRAMS = tests/testsuite stabbertests/testsuite
+tests_testsuite_SOURCES = $(test_sources)
 tests_testsuite_LDADD = -lcmocka
+stabbertests_testsuite_SOURCES = $(stabbertest_sources)
+stabbertests_testsuite_LDADD = -lcmocka -lstabber
 
 man_MANS = $(man_sources)