about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-05-08 00:07:21 +0100
committerJames Booth <boothj5@gmail.com>2015-05-08 00:07:21 +0100
commitacd2d2309f164a4902c3cfd7dc5b1ed5d2f7aa71 (patch)
treea3cad163417ad8b182ed04a75474ece1ff701fd7 /Makefile.am
parent0db7bcbdcdbc2039033b6c18d5610372969556bc (diff)
downloadprofani-tty-acd2d2309f164a4902c3cfd7dc5b1ed5d2f7aa71.tar.gz
Moved pgp signature generation to cl_ev_presence_send
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b59da17..0da3aacd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -68,7 +68,6 @@ tests_sources = \
 	src/event/ui_events.c src/event/ui_events.h \
 	tests/xmpp/stub_xmpp.c \
 	tests/ui/stub_ui.c \
-	tests/pgp/stub_gpg.c \
 	tests/log/stub_log.c \
 	tests/config/stub_accounts.c \
 	tests/helpers.c tests/helpers.h \
@@ -103,6 +102,9 @@ git_include = src/gitversion.h
 pgp_sources = \
 	src/pgp/gpg.h src/pgp/gpg.c
 
+pgp_test_sources = \
+	tests/pgp/stub_gpg.c
+
 otr3_sources = \
 	src/otr/otrlib.h src/otr/otrlibv3.c src/otr/otr.h src/otr/otr.c
 
@@ -120,6 +122,7 @@ man_sources = docs/profanity.1
 
 if BUILD_PGP
 core_sources += $(pgp_sources)
+tests_sources += $(pgp_test_sources)
 endif
 
 if BUILD_OTR