about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-07-20 23:28:23 +0100
committerJames Booth <boothj5@gmail.com>2015-07-20 23:28:23 +0100
commitc5a04de9fbc05acbd77219c2bbe1e315743a7ef2 (patch)
tree3acc1f7ba58c5209c639551ea03b32ef1381fe05 /Makefile.am
parentd40998c4affcb76acea42b25455deb087f544dfc (diff)
downloadprofani-tty-c5a04de9fbc05acbd77219c2bbe1e315743a7ef2.tar.gz
Added libexpect check for functional tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 88254721..87bc1502 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -162,12 +162,14 @@ tests_unittests_unittests_CFLAGS = -w
 tests_unittests_unittests_LDADD = -lcmocka
 
 if HAVE_STABBER
+if HAVE_EXPECT
 TESTS += tests/functionaltests/functionaltests
 check_PROGRAMS += tests/functionaltests/functionaltests
 tests_functionaltests_functionaltests_SOURCES = $(functionaltest_sources)
 tests_functionaltests_functionaltests_CFLAGS = -I/usr/include/tcl8.6 -I/usr/include/tcl8.5
 tests_functionaltests_functionaltests_LDADD = -lcmocka -lstabber -lexpect -ltcl
 endif
+endif
 
 man_MANS = $(man_sources)