about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2013-09-17 00:59:37 +0100
committerJames Booth <boothj5@gmail.com>2013-09-17 00:59:37 +0100
commitd782b00711ddb3925738626e5509191932164975 (patch)
tree76c7381b9d749249fe55991504782e73ae556e4f /Makefile.am
parente9361f834ae42e3218712d25f0d532dd1f1dc6b9 (diff)
downloadprofani-tty-d782b00711ddb3925738626e5509191932164975.tar.gz
Added git branch and revision to development builds
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am65
1 files changed, 35 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index 45d8a9c0..9a4c96d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,33 +1,18 @@
-bin_PROGRAMS = profanity
-profanity_SOURCES = \
-	src/contact.c src/contact.h src/log.c src/common.c \
-	src/log.h src/profanity.c src/common.h \
-	src/main.c src/profanity.h src/chat_session.c \
-	src/chat_session.h src/muc.c src/muc.h src/jid.h src/jid.c \
-	src/resource.c src/resource.h \
-	src/xmpp/xmpp.h src/xmpp/capabilities.c src/xmpp/connection.c \
-	src/xmpp/iq.c src/xmpp/message.c src/xmpp/presence.c src/xmpp/stanza.c \
-	src/xmpp/stanza.h src/xmpp/message.h src/xmpp/iq.h src/xmpp/presence.h \
-	src/xmpp/capabilities.h src/xmpp/connection.h \
-	src/xmpp/roster.c src/xmpp/roster.h \
-	src/xmpp/bookmark.c src/xmpp/bookmark.h \
-	src/ui/ui.h src/ui/window.c src/ui/window.h src/ui/core.c \
-	src/ui/titlebar.c src/ui/statusbar.c src/ui/inputwin.c \
-	src/ui/console.c src/ui/notifier.c src/ui/notifier.h \
-    src/ui/windows.c src/ui/windows.h \
-	src/command/command.h src/command/command.c src/command/history.c \
-	src/command/history.h src/tools/parser.c \
-	src/tools/parser.h \
-	src/tools/autocomplete.c src/tools/autocomplete.h \
-	src/tools/history.c src/tools/history.h \
-	src/tools/tinyurl.c src/tools/tinyurl.h \
-	src/config/accounts.c src/config/accounts.h \
-	src/config/preferences.c src/config/preferences.h \
-	src/config/theme.c src/config/theme.h
+if INCLUDE_GIT_VERSION
+src/gitversion.c: .git/HEAD .git/index
+	rm -f src/gitversion.c src/gitversion.o
+	echo "#ifndef PROF_GIT_BRANCH" >> $@
+	echo "#define PROF_GIT_BRANCH \"$(shell git rev-parse --symbolic-full-name --abbrev-ref HEAD)\"" >> $@
+	echo "#endif" >> $@
+	echo "#ifndef PROF_GIT_REVISION" >> $@
+	echo "#define PROF_GIT_REVISION \"$(shell git log --pretty=format:'%h' -n 1)\"" >> $@
+	echo "#endif" >> $@
 
-TESTS = tests/testsuite
-check_PROGRAMS = tests/testsuite
-tests_testsuite_SOURCES = \
+clean-local:
+	rm -f src/gitversion.c src/gitversion.o
+endif
+
+core_sources = \
 	src/contact.c src/contact.h src/log.c src/common.c \
 	src/log.h src/profanity.c src/common.h \
 	src/profanity.h src/chat_session.c \
@@ -51,10 +36,30 @@ tests_testsuite_SOURCES = \
 	src/tools/tinyurl.c src/tools/tinyurl.h \
 	src/config/accounts.c src/config/accounts.h \
 	src/config/preferences.c src/config/preferences.h \
-	src/config/theme.c src/config/theme.h \
+	src/config/theme.c src/config/theme.h
+
+test_sources = \
 	tests/test_roster.c tests/test_common.c tests/test_history.c \
 	tests/test_autocomplete.c tests/testsuite.c tests/test_parser.c \
 	tests/test_jid.c
+
+main_source = src/main.c
+
+git_sources = \
+    src/gitversion.c
+
+if INCLUDE_GIT_VERSION
+with_git_sources = $(git_sources) $(core_sources)
+else
+with_git_sources = $(core_sources)
+endif
+
+bin_PROGRAMS = profanity
+profanity_SOURCES = $(main_source) $(with_git_sources)
+
+TESTS = tests/testsuite
+check_PROGRAMS = tests/testsuite
+tests_testsuite_SOURCES = $(with_git_sources) $(test_sources)
 tests_testsuite_LDADD = -lheadunit -lstdc++
 
 man_MANS = docs/profanity.1