about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-02-09 00:32:11 +0000
committerJames Booth <boothj5@gmail.com>2014-02-09 00:32:11 +0000
commitfa89e2aa628c769540a73989759394f2bd7744c1 (patch)
treeefdadc4ad612fde5f75ca167851d02a838d79aeb /Makefile.am
parent50afe7366e00767208fc9d17167a768cf924d6cb (diff)
downloadprofani-tty-fa89e2aa628c769540a73989759394f2bd7744c1.tar.gz
Check for libotr version
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c3388d2..9bea1a50 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,8 +94,11 @@ main_source = src/main.c
 git_sources = \
     src/gitversion.c
 
-otr_sources = \
-    src/otr.c src/otr.h
+otr3_sources = \
+    src/otr3.c src/otr.h
+
+otr4_sources = \
+    src/otr4.c src/otr.h
 
 if INCLUDE_GIT_VERSION
 with_git_sources = $(git_sources) $(core_sources)
@@ -105,9 +108,15 @@ with_git_sources = $(core_sources)
 tests_with_git_sources = $(test_sources)
 endif
 
+if BUILD_OTR
 if BUILD_OTR3
-with_otr_sources = $(with_git_sources) $(otr_sources)
-tests_with_otr_sources = $(tests_with_git_sources) $(otr_sources)
+with_otr_sources = $(with_git_sources) $(otr3_sources)
+tests_with_otr_sources = $(tests_with_git_sources) $(otr3_sources)
+endif
+if BUILD_OTR4
+with_otr_sources = $(with_git_sources) $(otr4_sources)
+tests_with_otr_sources = $(tests_with_git_sources) $(otr4_sources)
+endif
 else
 with_otr_sources = $(with_git_sources)
 tests_with_otr_sources = $(tests_with_git_sources)