about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2013-03-24 18:15:43 +0200
committerDmitry Podgorny <pasis.ua@gmail.com>2013-03-24 18:16:09 +0200
commit131034eceddbe7db95313ce43c1292811e4b4c54 (patch)
tree86b197173df0f8e0758e2fddc8c0b7fb76e86c03 /configure.ac
parent9cef1ea52793c454c6f4766ce22ddedbc2d83bb1 (diff)
downloadprofani-tty-131034eceddbe7db95313ce43c1292811e4b4c54.tar.gz
Add -Werror only for development builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 45badb0e..ceaf1751 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,8 @@
 
 AC_PREREQ([2.65])
 AC_INIT([profanity], [0.3.0], [boothj5web@gmail.com])
-AC_DEFINE([PACKAGE_STATUS], ["development"], [Status of this build])
+PACKAGE_STATUS="development"
+AC_DEFINE_UNQUOTED([PACKAGE_STATUS], ["$PACKAGE_STATUS"], [Status of this build])
 AC_CONFIG_SRCDIR([src/main.c])
 AC_CONFIG_HEADERS([src/config.h])
 AC_CONFIG_AUX_DIR([build-aux])
@@ -87,7 +88,10 @@ if test "x$enable_notifications" != xno; then
 fi
 
 # Default parameters
-AM_CFLAGS="-Wall -Werror"
+AM_CFLAGS="-Wall"
+if test "x$PACKAGE_STATUS" = xdevelopment; then
+    AM_CFLAGS="$AM_CFLAGS -Wunused -Werror"
+fi
 LIBS="$LIBS $DEPS_LIBS $NOTIFY_LIBS"
 
 AM_CPPFLAGS="$DEPS_CFLAGS $NOTIFY_CFLAGS"