about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-03-22 00:12:14 +0000
committerJames Booth <boothj5@gmail.com>2015-03-22 00:12:14 +0000
commit2490c3ed202a912438d34594c01811f7532430a4 (patch)
treeb8dd9563c6f1bf4c320d60d525507d70adf720bb /configure.ac
parentf1f047889eed360a0c91be4fcabd24199089c02a (diff)
downloadprofani-tty-2490c3ed202a912438d34594c01811f7532430a4.tar.gz
Added pgp key list command
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0653ab68..96b0e3ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,8 @@ AC_ARG_ENABLE([notifications],
     [AS_HELP_STRING([--enable-notifications], [enable desktop notifications])])
 AC_ARG_ENABLE([otr],
     [AS_HELP_STRING([--enable-otr], [enable otr encryption])])
+AC_ARG_ENABLE([pgp],
+    [AS_HELP_STRING([--enable-pgp], [enable pgp])])
 AC_ARG_WITH([libxml2],
     [AS_HELP_STRING([--with-libxml2], [link with libxml2 instead of expat])])
 AC_ARG_WITH([xscreensaver],
@@ -183,6 +185,17 @@ elif test "x$with_xscreensaver" = x; then
         [AC_MSG_NOTICE([libX11 not found, falling back to profanity auto-away])])
 fi
 
+AM_CONDITIONAL([BUILD_PGP], [false])
+if test "x$enable_pgp" = xyes; then
+    AC_CHECK_LIB([gpgme], [main],
+        [AM_CONDITIONAL([BUILD_PGP], [true]) LIBS="-lgpgme $LIBS" AC_DEFINE([HAVE_LIBGPGME], [1], [Have libgpgme])],
+        [AC_MSG_ERROR([libgpgme is required for profanity])])
+elif test "x$enable_pgp" = x; then
+    AC_CHECK_LIB([gpgme], [main],
+        [AM_CONDITIONAL([BUILD_PGP], [true]) LIBS="-lgpgme $LIBS" AC_DEFINE([HAVE_LIBGPGME], [1], [Have libgpgme])],
+        [AC_MSG_NOTICE([libgpgme not found, pgp support not included.])])
+fi
+
 AM_CONDITIONAL([BUILD_OTR], [false])
 AM_CONDITIONAL([BUILD_OTR3], [false])
 AM_CONDITIONAL([BUILD_OTR4], [false])