about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2020-06-05 19:37:53 +0200
committerMichael Vetter <jubalh@iodoru.org>2020-06-05 19:37:53 +0200
commit28bdbf8ea136eff1a98760a78784d78ff711ebfd (patch)
tree1122ff8ac8841148fcc02d3721303ae92b45993b /configure.ac
parentac7abc54757460638e089ceed829f1987a51172e (diff)
downloadprofani-tty-28bdbf8ea136eff1a98760a78784d78ff711ebfd.tar.gz
Bump libstrophe requirement to 0.9.3
legacy auth (ac410445af65b9d332d4606a08ff549672042766) requires
libstrophe 0.9.3 because of XMPP_CONN_FLAG_LEGACY_AUTH.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 69b76697..e18d9823 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,11 +129,11 @@ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
 AS_IF([test "x$PTHREAD_CC" != x], [ CC="$PTHREAD_CC" ])
 
 ### Check for libmesode, fall back to libstrophe
-PKG_CHECK_MODULES([libmesode], [libmesode >= 0.9.2],
+PKG_CHECK_MODULES([libmesode], [libmesode >= 0.9.3],
     [LIBS="$libmesode_LIBS $LIBS" CFLAGS="$CFLAGS $libmesode_CFLAGS" XMPP_LIB="libmesode" AC_DEFINE([HAVE_LIBMESODE], [1], [libmesode])],
-    [PKG_CHECK_MODULES([libstrophe], [libstrophe >= 0.9.2],
+    [PKG_CHECK_MODULES([libstrophe], [libstrophe >= 0.9.3],
         [LIBS="$libstrophe_LIBS $LIBS" CFLAGS="$CFLAGS $libstrophe_CFLAGS" XMPP_LIB="libstrophe" AC_DEFINE([HAVE_LIBSTROPHE], [1], [libstrophe])],
-        [AC_MSG_ERROR([Neither libmesode or libstrophe in version >= 0.9.2 found, either is required for profanity])])])
+        [AC_MSG_ERROR([Neither libmesode or libstrophe in version >= 0.9.3 found, either is required for profanity])])])
 
 AC_MSG_CHECKING([whether ${XMPP_LIB} works])
 AC_LINK_IFELSE([AC_LANG_SOURCE([[