about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2012-07-01 16:18:57 +0100
committerJames Booth <boothj5@gmail.com>2012-07-01 16:18:57 +0100
commit28f5cdf786774cf683821012be36605cbcab0893 (patch)
tree19df9ea4b00a17b0e9f8f348d024f9e8c0998816 /configure.ac
parent2655d9e8fad38acd4ce7388c0ba3eaaa976d6940 (diff)
downloadprofani-tty-28f5cdf786774cf683821012be36605cbcab0893.tar.gz
Added libnotify headers to configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1559d287..32dda324 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,23 +12,27 @@ AC_PROG_CC
 
 # Checks for libraries.
 # FIXME: Replace `main' with a function in `-lexpat':
-AC_CHECK_LIB([expat], [main])
+AC_CHECK_LIB([expat], [main], [], [AC_MSG_ERROR([expat is required for profanity])])
 # FIXME: Replace `main' with a function in `-lncurses':
-AC_CHECK_LIB([ncurses], [main])
+AC_CHECK_LIB([ncurses], [main], [], [AC_MSG_ERROR([ncurses is required for profanity])])
 # FIXME: Replace `main' with a function in `-lresolv':
-AC_CHECK_LIB([resolv], [main])
+AC_CHECK_LIB([resolv], [main], [], [AC_MSG_ERROR([libresolv is required for profanity])])
 # FIXME: Replace `main' with a function in `-lssl':
-AC_CHECK_LIB([ssl], [main])
+AC_CHECK_LIB([ssl], [main], [], [AC_MSG_ERROR([openssl is required for profanity])])
 # FIXME: Replace `main' with a function in `-lstrophe':
-AC_CHECK_LIB([strophe], [main])
+AC_CHECK_LIB([strophe], [main], [], [AC_MSG_ERROR([libstrophe is required for profanity])])
 # FIXME: Replace `main' with a function in `-lxml2':
-AC_CHECK_LIB([xml2], [main])
+AC_CHECK_LIB([xml2], [main], [], [AC_MSG_ERROR([xml2 is required for profanity])])
+AC_CHECK_LIB([glib], [main], [], [AC_MSG_ERROR([glib is required for profanity])])
+
+CFLAGS="$CFLAGS `pkg-config --cflags --libs libnotify`" 
 
 # Checks for header files.
 AC_CHECK_HEADERS([stdlib.h string.h])
-
 # Checks for typedefs, structures, and compiler characteristics.
 
+AC_CHECK_HEADERS([libnotify/notify.h], [], [AC_MSG_NOTICE([libnotify not found, desktop notification option not included])])
+
 # Checks for library functions.
 AC_FUNC_MALLOC
 AC_CHECK_FUNCS([atexit memset strdup strndup strstr])