about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-03-08 23:38:30 +0000
committerJames Booth <boothj5@gmail.com>2014-03-08 23:38:30 +0000
commit2b3d64514712e17f52dd7df3e4d1bfa41c92c892 (patch)
tree8e76d6041f9c9e3dbb2dc3d7f95a48719495d76d /configure.ac
parent13ee16dedb0cc18801b211d666aae0dcd71dd50b (diff)
downloadprofani-tty-2b3d64514712e17f52dd7df3e4d1bfa41c92c892.tar.gz
Added other osx build options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b2a284b0..3abf8c1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,11 +206,13 @@ AS_IF([test "x$PACKAGE_STATUS" = xdevelopment],
 AM_CPPFLAGS="$AM_CPPFLAGS $glib_CFLAGS $curl_CFLAGS $libnotify_CFLAGS"
 LIBS="$LIBS $glib_LIBS $curl_LIBS $libnotify_LIBS"
 
+AS_IF([test "x$PLATFORM" = xosx], [LIBS="$LIBS -lncurses -lcurl"])
+
 AC_SUBST(AM_CFLAGS)
 AC_SUBST(AM_CPPFLAGS)
 
 ### Checks for library functions.
-AC_FUNC_MALLOC
+AS_IF([test "x$PLATFORM" != xosx], [AC_FUNC_MALLOC])
 AC_CHECK_FUNCS([atexit memset strdup strstr])
 
 AC_CONFIG_FILES([Makefile])