about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-01-16 22:55:30 +0000
committerJames Booth <boothj5@gmail.com>2014-01-16 22:55:30 +0000
commit3f73cb7732c98737ae9d39a4b0d97ed4235a283d (patch)
treed3b9798763733c0e336bb18c75eefec8e07b9b3e /configure.ac
parent4f98bc8c25075891a1fd5a954ae83e961405a664 (diff)
downloadprofani-tty-3f73cb7732c98737ae9d39a4b0d97ed4235a283d.tar.gz
Fixed configure.ac for --disable-otr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 708432b1..acad1fb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,8 @@ AM_CONDITIONAL([BUILD_OTR], [true])
 if test "x$enable_otr" = xyes; then
     AC_CHECK_LIB([otr], [main], [],
         [AC_MSG_ERROR([libotr is required for otr encryption support])])
+elif test "x$enable_otr" = xno; then
+    AM_CONDITIONAL([BUILD_OTR], [false])
 elif test "x$enable_otr" = x; then
     AC_CHECK_LIB([otr], [main], [],
         [AM_CONDITIONAL([BUILD_OTR], [false]) AC_MSG_NOTICE([libotr not found, otr entryption support not enabled])])