about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2022-02-17 20:57:52 +0100
committerMichael Vetter <jubalh@iodoru.org>2022-02-18 14:01:28 +0100
commit3f8720d70f6b4497ef2369a1e7e9b8fbebb4f5bd (patch)
tree5f0c10df2250d8e98dbd4e736a4734dc97a8c706 /configure.ac
parent1856c1e7fcb40aaa8a8ee19dbcac7818941c4b11 (diff)
downloadprofani-tty-3f8720d70f6b4497ef2369a1e7e9b8fbebb4f5bd.tar.gz
build: remove support for old libsignal
Remove support for libsignal-protocol-c < 2.3.2.
Debian 10 uses 2.3.2, Debian 11 and 12 use 2.3.3.
openSUSE from 15.2 onward uses 2.3.3.
Fedora since 28 uses 2.3.2.

We should be good.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 2246adbf..f625c9c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,14 +324,7 @@ if test "x$enable_omemo" != xno; then
    AM_CONDITIONAL([BUILD_OMEMO], [true])
     PKG_CHECK_MODULES([libsignal], [libsignal-protocol-c >= 2.3.2],
         [LIBS="-lsignal-protocol-c $LIBS"],
-        [AC_MSG_NOTICE([libsignal >= 2.3.2 not found, checking for libsignal 2.3.x...])
-         PKG_CHECK_MODULES([libsignal], [libsignal-protocol-c >= 2.3.0],
-            [LIBS="-lsignal-protocol-c $LIBS"
-             AC_DEFINE([HAVE_LIBSIGNAL_LT_2_3_2], [1], [Have libsignal-protocol-c < 2.3.2])],
-            [AM_CONDITIONAL([BUILD_OMEMO], [false])
-             AS_IF([test "x$enable_omemo" = xyes],
-                   [AC_MSG_ERROR([libsignal-protocol-c is required for OMEMO support])],
-                   [AC_MSG_NOTICE([libsignal-protocol-c not found, OMEMO support not enabled])])])])
+        [AC_MSG_NOTICE([libsignal-protocol-c >= 2.3.2 not found, OMEMO support not enabled])])
 
     AC_CHECK_LIB([gcrypt], [gcry_md_extract],
         [LIBS="-lgcrypt $LIBS"],