about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Fariello <paul@fariello.eu>2019-02-19 06:24:47 +0140
committerPaul Fariello <paul@fariello.eu>2019-04-08 11:50:12 +0200
commit4a5b672f95266990549ddc7eb2366a99cfddeefa (patch)
treee40106e6c58b82de1e5b23ab2b4a176a6f814026 /configure.ac
parent6b064cfde4456c25bd9dbcbfe0a79262ebcb3599 (diff)
downloadprofani-tty-4a5b672f95266990549ddc7eb2366a99cfddeefa.tar.gz
Link against libsignal-protocol-c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b8e4512..9cce9840 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,8 @@ AC_ARG_ENABLE([otr],
     [AS_HELP_STRING([--enable-otr], [enable otr encryption])])
 AC_ARG_ENABLE([pgp],
     [AS_HELP_STRING([--enable-pgp], [enable pgp])])
+AC_ARG_ENABLE([omemo],
+    [AS_HELP_STRING([--enable-omemo], [enable omemo encryption])])
 AC_ARG_WITH([xscreensaver],
     [AS_HELP_STRING([--with-xscreensaver], [use libXScrnSaver to determine idle time])])
 AC_ARG_WITH([themes],
@@ -264,6 +266,17 @@ if test "x$enable_otr" != xno; then
             [AC_MSG_NOTICE([libotr not found, otr encryption support not enabled])])])
 fi
 
+AM_CONDITIONAL([BUILD_OMEMO], [false])
+if test "x$enable_omemo" != xno; then
+    AC_CHECK_LIB([signal-protocol-c], [signal_context_create],
+        [AM_CONDITIONAL([BUILD_OMEMO], [true])
+         AC_DEFINE([HAVE_LIBSIGNAL_PROTOCOL], [1], [Have omemo]),
+         LIBS="-lsignal-protocol-c $LIBS"],
+        [AS_IF([test "x$enable_omemo" = xyes],
+            [AC_MSG_ERROR([libsignal-protocol-c is required for omemo support])],
+            [AC_MSG_NOTICE([libsignal-protocol-c not found, omemo support not enabled])])])
+fi
+
 AS_IF([test "x$with_themes" = xno],
     [THEMES_INSTALL="false"],
     [THEMES_INSTALL="true"])