about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-01-12 01:25:35 +0000
committerJames Booth <boothj5@gmail.com>2014-01-12 01:25:35 +0000
commit4e97c1e460d150b0cde6d8e35d8caf7bcf959a71 (patch)
tree182a76fd90bdc61f711d9c1d7ddd8f297d72c86e /configure.ac
parent462e84ea8218d267164ea563ea00412e57e3fb41 (diff)
parentf1bd350567aad2de409f53e0c5b0870366b56bac (diff)
downloadprofani-tty-4e97c1e460d150b0cde6d8e35d8caf7bcf959a71.tar.gz
Merge branch 'master' into otr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9fe3c201..4fb4deda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,8 +62,9 @@ AM_CPPFLAGS="$AM_CPPFLAGS $PARSER_CFLAGS"
 LIBS="$LIBS $PARSER_LIBS"
 
 ### Check for libstrophe dependencies
-AC_CHECK_LIB([resolv], [__res_query], [],
-    [AC_MSG_ERROR([libresolv is required for profanity])])
+AC_CHECK_LIB([resolv], [res_query], [],
+    [AC_CHECK_LIB([resolv], [__res_query], [],
+        [AC_MSG_ERROR([libresolv is required for profanity])])])
 PKG_CHECK_MODULES([openssl], [openssl], [],
     [AC_MSG_ERROR([openssl is required for profanity])])
 AM_CPPFLAGS="$AM_CPPFLAGS $openssl_CFLAGS"