about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-02-08 23:29:42 +0000
committerJames Booth <boothj5@gmail.com>2014-02-08 23:29:42 +0000
commit50afe7366e00767208fc9d17167a768cf924d6cb (patch)
tree638ce0d08faaee1e3153d026dcd0e9c4d78119c2 /configure.ac
parent7e4b1b1dea89ff404bf9b75a380c064d78255239 (diff)
downloadprofani-tty-50afe7366e00767208fc9d17167a768cf924d6cb.tar.gz
Use AC_SEARCH_LIBS for otr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6661e40b..aed16cd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,12 +133,12 @@ fi
 
 AM_CONDITIONAL([BUILD_OTR3], [false])
 if test "x$enable_otr" = xyes; then
-    AC_CHECK_LIB([otr], [main],
-        [AM_CONDITIONAL([BUILD_OTR3], [true])],
+    AC_SEARCH_LIBS([otrl_init], [otr],
+        [AM_CONDITIONAL([BUILD_OTR3], [true]) AC_DEFINE([HAVE_LIBOTR], [1], [Have libotr])],
         [AC_MSG_ERROR([libotr is required for otr encryption support])])
 elif test "x$enable_otr" = x; then
-    AC_CHECK_LIB([otr], [main],
-        [AM_CONDITIONAL([BUILD_OTR3], [true])],
+    AC_SEARCH_LIBS([otrl_init], [otr],
+        [AM_CONDITIONAL([BUILD_OTR3], [true]) AC_DEFINE([HAVE_LIBOTR], [1], [Have libotr])],
         [AC_MSG_NOTICE([libotr not found, otr entryption support not enabled])])
 fi