about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-06-22 18:48:00 +0100
committerJames Booth <boothj5@gmail.com>2015-06-22 18:48:00 +0100
commit54df2101be63616121d8c6a67fcb37b2375a910c (patch)
tree8094073cf4acf404180d8e8c72f4beb1f6bb5e8c /configure.ac
parentfdb50f77e78772512e76a0e368c8d31c2cd94722 (diff)
downloadprofani-tty-54df2101be63616121d8c6a67fcb37b2375a910c.tar.gz
Tidied gpgme check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a652abfb..aefd028d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,14 +189,12 @@ elif test "x$with_xscreensaver" = x; then
 fi
 
 AM_CONDITIONAL([BUILD_PGP], [false])
-if test "x$enable_pgp" = xyes; then
+if test "x$enable_pgp" != xno; then
     AC_CHECK_LIB([gpgme], [main],
         [AM_CONDITIONAL([BUILD_PGP], [true]) LIBS="-lgpgme $LIBS" AC_DEFINE([HAVE_LIBGPGME], [1], [Have libgpgme])],
-        [AC_MSG_ERROR([libgpgme is required for profanity])])
-elif test "x$enable_pgp" = x; then
-    AC_CHECK_LIB([gpgme], [main],
-        [AM_CONDITIONAL([BUILD_PGP], [true]) LIBS="-lgpgme $LIBS" AC_DEFINE([HAVE_LIBGPGME], [1], [Have libgpgme])],
-        [AC_MSG_NOTICE([libgpgme not found, pgp support not included.])])
+        [AS_IF([test "x$enable_pgp" = xyes],
+            [AC_MSG_ERROR([libgpgme is required for pgp support])],
+            [AC_MSG_NOTICE([libgpgme not found, pgp support not enabled])])])
 fi
 
 AM_CONDITIONAL([BUILD_OTR], [false])