about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-06-01 22:42:10 +0100
committerJames Booth <boothj5@gmail.com>2014-06-01 22:42:10 +0100
commit575b6acdd257d153901b248e55eea3b35a6ad441 (patch)
treed4f782f0e365d76da853c1a8e24d161654f69177 /configure.ac
parent355cd27f6c3f34f0fef17fdbbfc7bc8222c8451a (diff)
downloadprofani-tty-575b6acdd257d153901b248e55eea3b35a6ad441.tar.gz
Use public domain SHA1 code, remove libgcrypt dependency
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c9886277..3c5c6463 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,7 +122,6 @@ PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.26], [],
     [AC_MSG_ERROR([glib 2.26 or higher is required for profanity])])
 PKG_CHECK_MODULES([curl], [libcurl], [],
     [AC_MSG_ERROR([libcurl is required for profanity])])
-AX_LIB_GCRYPT([yes])
 
 AS_IF([test "x$PLATFORM" = xosx], [LIBS="$LIBS -lcurl"])
 
@@ -218,9 +217,9 @@ AC_CHECK_HEADERS([ncurses.h], [], [])
 AM_CFLAGS="-Wall -Wno-deprecated-declarations"
 AS_IF([test "x$PACKAGE_STATUS" = xdevelopment],
     [AM_CFLAGS="$AM_CFLAGS -Wunused -Werror"])
-AM_CPPFLAGS="$AM_CPPFLAGS $glib_CFLAGS $curl_CFLAGS $libnotify_CFLAGS $GCRYPT_CFLAGS"
+AM_CPPFLAGS="$AM_CPPFLAGS $glib_CFLAGS $curl_CFLAGS $libnotify_CFLAGS"
 AM_CPPFLAGS="$AM_CPPFLAGS -DTHEMES_PATH=\"\\\"$THEMES_PATH\\\"\""
-LIBS="$LIBS $glib_LIBS $curl_LIBS $libnotify_LIBS $GCRYPT_LIBS"
+LIBS="$LIBS $glib_LIBS $curl_LIBS $libnotify_LIBS"
 
 AC_SUBST(AM_CFLAGS)
 AC_SUBST(AM_CPPFLAGS)