about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-02-25 22:50:25 +0000
committerJames Booth <boothj5@gmail.com>2014-02-25 22:50:25 +0000
commit5b734156a5ef0147396f328fe523f07d02d24ff5 (patch)
tree85eedcf3d5dc8962bc22327a3496f71296dbbc44 /configure.ac
parenta0df7f79446fde68a7610de7de374b74880e5dd9 (diff)
downloadprofani-tty-5b734156a5ef0147396f328fe523f07d02d24ff5.tar.gz
Changes to get install-all.sh working on fresh opensuse VM
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index efe4fcc3..f9b8f31d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,8 +82,9 @@ PKG_CHECK_MODULES([ncursesw], [ncursesw],
     [NCURSES_CFLAGS="$ncursesw_CFLAGS"; NCURSES_LIBS="$ncursesw_LIBS"; NCURSES="ncursesw"],
     [PKG_CHECK_MODULES([ncurses], [ncurses],
         [NCURSES_CFLAGS="$ncurses_CFLAGS"; NCURSES_LIBS="$ncurses_LIBS"; NCURSES="ncurses"],
-        [AC_CHECK_LIB([ncurses], [main], [],
-            [AC_MSG_ERROR([ncurses is required for profanity])])])])
+        [AC_CHECK_LIB([ncursesw], [main], [],
+            [AC_CHECK_LIB([ncurses], [main], [],
+            	[AC_MSG_ERROR([ncurses is required for profanity])])])])])
 AM_CPPFLAGS="$AM_CPPFLAGS $NCURSES_CFLAGS"
 LIBS="$LIBS $NCURSES_LIBS"