about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2013-01-05 19:58:24 +0000
committerJames Booth <boothj5@gmail.com>2013-01-05 19:58:24 +0000
commit78841f2ea393280066db0f802d825d596422bfe6 (patch)
tree7b094053ea5253acf76afb27ae07d504dc1d9194 /configure.ac
parentd20354968a4968b4a7dc1b38886f387aff981135 (diff)
downloadprofani-tty-78841f2ea393280066db0f802d825d596422bfe6.tar.gz
Added libx11 when --with-xscreensaver chosen
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 972c0609..a2a0ee91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,10 +45,15 @@ fi
 
 if test "x$with_xscreensaver" = xyes; then
     AC_CHECK_LIB([Xss], [main], [],
-        [AC_MSG_ERROR([libXss is required for xscreensaver support])])
+        [AC_MSG_ERROR([libXss is required for x autoaway support])])
+    AC_CHECK_LIB([X11], [main], [], 
+        [AC_MSG_NOTICE([libX11 is required for x autoaway support])])
 elif test "x$with_xscreensaver" = x; then
     AC_CHECK_LIB([Xss], [main], [],
         [AC_MSG_NOTICE([libXss not found, falling back to profanity auto-away])])
+    AC_CHECK_LIB([X11], [main], [], 
+        [AC_MSG_NOTICE([libX11 not found, falling back to profanity auto-away])])
+
 fi
 
 AC_CHECK_LIB([resolv], [main], [],